Results 1 to 6 of 6
  1. #1

    Join Date
    Sep 2008
    Location
    Boca Raton, Florida
    Posts
    30

    Water supposed to get in here?

    I was putting my ski back together when i found a left over O-Ring so i
    looked on the bench where i had everything layed out in order and it was
    a O-Ring from carb 1 so i break it all back down after testing for water
    leaks in the system on the hose and when i un did the rear exhuast
    clamps water poured every where from the back.

    So my question is, is water supposed to get into this aluminum pipe,
    before going up the other plastic pipes and exiting the rear of the ski?





  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Did you rev the ski after shutting the water off? Did you shut the ski off before shutting off the water source? Water is supposed to be in the "water box".

  3. #3

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    Yes, the bottom of the exhaust stinger is what clamps into that aluminum water box, and there are 4 water jet ports in that stinger that shoot water right there. Its for cooling the exhaust, and also for high rpm tuning of the pipe.

  4. #4
    Quote Originally Posted by WATER WOODY View Post
    Did you rev the ski after shutting the water off? Did you shut the ski off before shutting off the water source? Water is supposed to be in the "water box".
    +1


    ... but to answer your question, yes... water is supposed to be in there.

  5. #5

    Join Date
    Sep 2008
    Location
    Boca Raton, Florida
    Posts
    30
    Thanks guys!

    I assumed water was supposed to go in there since there was no direct
    way to block it off. only about 8 cups came out.

    The ski was ran for about 3-5 minutes on the hose and i turned the water
    off after i shut the ski off, i quickly came back and and ran the ski for
    about 30-60 seconds reving it to about half throttle.

  6. #6

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Quote Originally Posted by BadBoyBill View Post
    The ski was ran for about 3-5 minutes on the hose and i turned the water
    off after i shut the ski off
    Turn the water off first!!! Then blip the throttle a couple of times and turn off ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. They're supposed to be in O-ring here? 2015 Px?
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-07-2016, 09:00 PM
  2. problems again please help would like to get in the water
    By freemandino25 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-12-2010, 08:24 PM
  3. Is water supposed to be in the downpipe where I mounted my oxygen sensor ?
    By eazygoin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-23-2010, 07:03 PM
  4. What water camera to get...
    By MIARider in forum Videos & Pictures
    Replies: 63
    Last Post: 06-08-2008, 10:55 AM
  5. Trying to get in contact with Carl-Island Racing
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-19-2008, 01:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •