Page 1 of 30 1 2 3 11 ... LastLast
Results 1 to 10 of 297
  1. #1
    SHO stopper palmbeach jesse's Avatar
    Join Date
    Nov 2007
    Location
    palm beach fl
    Posts
    3,225

    2rude test results

    I had the pleasure of testing the new 2rude supercharger for Nils today...
    I went to the st. johns river.I rode ski saturday without changing my set-up to have some base numbers to go by. Water temp was 86, air temp was 88, I installed a new boost gauge (20psi) before testing because my old gauge only read to 15psi.. (it was a crappy gauge) had condensation built up within a hour.... So Im not excact on boost readings...Rpms were way down (8520rpms) because of the heat. Best speed was 80.3

    That night I pulled the charger, and replaced it with the 2rude...
    This is the results. I didnt touch anything else at all...
    8760 rpms!!!!
    83.4mph

    same excact location, same temps, same everything ...except I put in the 2rude.
    I gained 3.1 mph , 220 rpms, and about 2 psi !!!
    The psi will be verified as soon as I get a new gauge...
    Also my charger slip is 7psi, I need to shim it....


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Nice numbers Jesse!!!!

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by palmbeach jesse View Post
    I had the pleasure of testing the new 2rude supercharger for Nils today...
    I went to the st. johns river.I rode ski saturday without changing my set-up to have some base numbers to go by. Water temp was 86, air temp was 88, I installed a new boost gauge (20psi) before testing because my old gauge only read to 15psi.. (it was a crappy gauge) had condensation built up within a hour.... So Im not excact on boost readings...Rpms were way down (8520rpms) because of the heat. Best speed was 80.3

    That night I pulled the charger, and replaced it with the 2rude...
    This is the results. I didnt touch anything else at all...
    8760 rpms!!!!
    83.4mph

    same excact location, same temps, same everything ...except I put in the 2rude.
    I gained 3,1 mph , 220 rpms, and about 2 psi !!!
    The psi will be verified as soon as I get a new gauge...
    Also my charger slip is 7psi, I need to shim it....
    Nice improvement

  4. #4
    Enufpwr's Avatar
    Join Date
    May 2005
    Location
    Lake St. Clair, Michigan
    Posts
    446
    AWESOME RESULTS!!!!



    Can't wait to get a 2rude charger

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Nice Test. I hate YOU!

    So your saying you dont have boost number comparison between the 2 SC. Man you need to get us a back to back test with boost difference.

    The rest of the info is great, Thanks

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    shim your current charger then test both SC`s need to have equal slip to get a good test IMHO

  7. #7
    SHO stopper palmbeach jesse's Avatar
    Join Date
    Nov 2007
    Location
    palm beach fl
    Posts
    3,225
    Quote Originally Posted by shhr View Post
    shim your current charger then test both SC`s need to have equal slip to get a good test IMHO
    it was the same shaft... just diferent front housing and impeller. So slip was the same both days

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    791
    Jesse, You have a RRFPR? Correct? With a RR ECU?

    I ask because I bet people are gonna need a RRFPR with a Riva ECU with this new 2Rude. So you were way to hot to run your normal 83 without this NEW SCer?

    .

  9. #9
    FIRED!!! JP's Avatar
    Join Date
    Dec 2006
    Location
    Fort Lauderdale, FLORIDA baby...
    Posts
    3,505
    Quote Originally Posted by palmbeach jesse View Post
    I had the pleasure of testing the new 2rude supercharger for Nils today...
    I went to the st. johns river.I rode ski saturday without changing my set-up to have some base numbers to go by. Water temp was 86, air temp was 88, I installed a new boost gauge (20psi) before testing because my old gauge only read to 15psi.. (it was a crappy gauge) had condensation built up within a hour.... So Im not excact on boost readings...Rpms were way down (8520rpms) because of the heat. Best speed was 80.3

    That night I pulled the charger, and replaced it with the 2rude...
    This is the results. I didnt touch anything else at all...
    8760 rpms!!!!
    83.4mph

    same excact location, same temps, same everything ...except I put in the 2rude.
    I gained 3.1 mph , 220 rpms, and about 2 psi !!!
    The psi will be verified as soon as I get a new gauge...
    Also my charger slip is 7psi, I need to shim it....
    you suck...

    NILS!!!
    WHERETHEHELL is MINE???

    JP

  10. #10

Page 1 of 30 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Test results: Modified stock grate VS Riva grate
    By Green Hulk in forum 4-Tec Performance
    Replies: 55
    Last Post: 09-23-2005, 10:39 AM
  2. Stock 05 RXP test results
    By RXPSC05 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-11-2005, 05:08 PM
  3. 05 RXP TEST RESULTS
    By RXPNJ in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-21-2005, 08:24 PM
  4. Today's test results 5/9/05
    By Jrsrxp in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-10-2005, 01:32 PM
  5. My Mods and test results
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-05-2005, 07:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •