Results 1 to 7 of 7

Thread: Bad Vibration

  1. #1

    Bad Vibration

    Hi guys im new to the whole jet ski world. Ive been on dirt bikes and atv's all my life. Well i just bought a 2006 seadoo rxp with 54 HRS. well this has happened to me twice yesterday. I would start up the jet ski and it would idle fine. But as soon as i give it a little gas i would get this really bad vibration. It would not go away for about ten min. Then i give it a quick burst of full throttle and it goes away. what do i need to do to have this problem fixed. Just remember i dont really know much about jet skis.

    Thanks John


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    How deep is the water that you're riding in? If it's less than 5' you may be sucking up debris from the bottom and jamming the pump. I would put the ski on the trailer and look carefully into the pump through the grate to see if anything is stuck in the impeller... Ron

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by John_29455 View Post
    Hi guys im new to the whole jet ski world. Ive been on dirt bikes and atv's all my life. Well i just bought a 2006 seadoo rxp with 54 HRS. well this has happened to me twice yesterday. I would start up the jet ski and it would idle fine. But as soon as i give it a little gas i would get this really bad vibration. It would not go away for about ten min. Then i give it a quick burst of full throttle and it goes away. what do i need to do to have this problem fixed. Just remember i dont really know much about jet skis.

    Thanks John
    Does it come and go??? Or have you not had it happen again to you since?

  4. #4
    gotpurp305's Avatar
    Join Date
    Feb 2006
    Location
    Miami
    Posts
    102
    happens to me sometimes, its usually just a lot of seaweed

  5. #5
    I do ride in some what shallow water. I looked into the impeller i didnt have anything that i could see. If its just trash then im no really going to worry about then. Could trash damage the impeller in anyway?

  6. #6
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by John_29455 View Post
    I do ride in some what shallow water. I looked into the impeller i didnt have anything that i could see. If its just trash then im no really going to worry about then. Could trash damage the impeller in anyway?
    That depends on what kind of trash your picking up. A little bit of sea weed, not really. A rock, yes.

  7. #7
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,061
    +1
    790
    I had the same issue. It ended up being that I had bent my prop from all the debri in my local lake.

    .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New guy with bad vibration/poor performance question
    By fatjeepkid in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-02-2010, 11:52 AM
  2. Bad Vibration SL780 HELP!
    By westpy1 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-22-2010, 06:03 PM
  3. Bad Vibration this weekend...
    By allstar71 in forum Yamaha PWC Performance (4-stroke)
    Replies: 29
    Last Post: 12-11-2009, 02:49 PM
  4. BAD vibration and loss of RPM!!!
    By RiseXagainst42 in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-09-2009, 12:00 AM
  5. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •