Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Tipped Ski

  1. #1
    07 Ultra 250x - Blue/Silver justice25's Avatar
    Join Date
    Jul 2008
    Location
    Lake City TN
    Posts
    92

    Question Tipped Ski

    A buddy of mine was tubing another friend on my Ultra this weekend and ran over the rope , while he was in tha water he tipped it over pretty far (without completly flipping the Ski) to see what he did. We towed it in and put it on the trailer, it took me about 1.5 hours to get the rope off of the shaft. After that we put it back in the Lake, but it would not run more than about 2,500 rpms and probably 15-20 mph at first, I puttet it around for a few min, and it cleared itself up. We then proceeded to ride it for about another Hour with no problems, I was just wondering if there is something that I need to look for, like maybe oil got into the Intercooler or something. This is my first Ski, so when something like this happens it always a first for me.


  2. #2
    Quote Originally Posted by justice25 View Post
    We then proceeded to ride it for about another Hour with no problems, I was just wondering if there is something that I need to look for, like maybe oil got into the Intercooler or something.
    What's the max RPM you are getting at WOT?
    Disconnect the hose between the s/c and the intercooler and inspect the inside hose wall for any water/oil residue.

  3. #3

    Join Date
    Sep 2008
    Location
    YOU CAN'T SEE ME
    Posts
    300
    Possible that piece of rope was still between pump housing and blade and after couple minutes of running it came on out. This is why i'll just snatch the pump off and remove all of it for sure. Takes about 30 minutes instead of 1 1/2 hrs of laying on my back and wondering if i got it all. A hard lesson i learned early on. I don't use ropes period on mine. If my ass ain't on the seat, its because my ride is on the trailer!

  4. #4
    Quote Originally Posted by bamatech View Post
    just snatch the pump off and remove all of it for sure. Takes about 30 minutes instead of 1 1/2 hrs of laying on my back and wondering if i got it all.
    If you ever take the ride plate off on the 250, make sure you carefully apply the sealant around the edges of the ride plate just like the factory had put on. Unlike other Kawi's 12/15 & many previous skis, the 250 (& LX) requires sealant between the ride plate and the hull bottom. But there is a way to remove the pump w/o removing the ride plate if you want to go that route.

  5. #5
    why is it a must to use sealant on the ride plate? when i installed my R&D plate i just cut the sealant off the stock rideplate before i removed the bolts, then when i removed the plate there was still the bead on the hull, the R&D plate fit flush up against the old sealant, did i do a no no?

  6. #6

    Join Date
    Sep 2008
    Location
    YOU CAN'T SEE ME
    Posts
    300
    I dont pull the plate, just the pump. Take a box cutter and slice the rope off and pop it back together. And yes, if it had sealer [from the FACTORY] before you took it apart, ya gotta put sealer back on AFTER you remove ALL of the old sealer.

  7. #7
    Quote Originally Posted by Stmpdust View Post
    why is it a must to use sealant on the ride plate? when i installed my R&D plate i just cut the sealant off the stock rideplate before i removed the bolts, then when i removed the plate there was still the bead on the hull, the R&D plate fit flush up against the old sealant, did i do a no no?
    If you are not experiencing cavitation after that, you are ok. But hard to believe...

  8. #8
    07 Ultra 250x - Blue/Silver justice25's Avatar
    Join Date
    Jul 2008
    Location
    Lake City TN
    Posts
    92
    I know that I got all of the rope because it was not cut, amaizingly it still had the factory knotted loop at the end, I will check the hose and IC tommorrow when I install my B.O.V. My RPM's are now hanging around 7600 which is where they usually are. Everything seems to be running fine now, it was just the inital 2-3 min it did not want to run. We took the rope straight off and started tubing with it again, so I know there was no rope in it. If you can think of anything else I need to check, please let me know.

  9. #9
    nighttrain nighttrain's Avatar
    Join Date
    Aug 2008
    Location
    MIAMI
    Posts
    92
    Quote Originally Posted by meangreenman View Post
    If you are not experiencing cavitation after that, you are ok. But hard to believe...

    Hi Meangreen, What does it feel like when you get cavitation?

  10. #10

    Join Date
    Sep 2008
    Location
    YOU CAN'T SEE ME
    Posts
    300
    Good deal justice. You should be good to go now.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Importing a ski into Canada - tips?
    By K447 in forum Polaris Open Discussion
    Replies: 21
    Last Post: 04-23-2010, 09:41 PM
  2. hero camera on the bow tip of ski!
    By jetdave56 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-03-2009, 07:45 PM
  3. Replies: 15
    Last Post: 03-04-2008, 03:08 PM
  4. Selling ski on Ebay - Need tips
    By 785xp in forum Open Discussion
    Replies: 7
    Last Post: 09-21-2007, 08:31 PM
  5. Need to turn ski on side any tips
    By tug145 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-18-2006, 04:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •