Results 1 to 9 of 9
  1. #1

    got a problem with my r12x

    hey guys having a problem with my r12x.it took in salt water after my drain plugs got loose.i changed the oil and put new spark plugs.it idlesfines and will drive from 0-20 mph fine any more fas and it locks miss fires crazy feels like a rev limiter any ideas?no ses light?


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    What year Ski is this? And how much water did you take on.

  3. #3
    its a 2005 and it took in alot of water,i havent taken it to the dealer yet seens its a bit far from me

  4. #4
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    2005 what? you said R12x on your first post and have F12x in your sig. What model are you talking about ?

  5. #5
    r12x the two seater

  6. #6
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    On that year the air filter and ECU is up front and high up near the glove box, Check the ECU connection but because of where its at it should be OK. if you see corrosion there, you will need to check all the ski connections.

    If its OK there, then check all the engine connections and sensors on the engine. put back dielectric grease on all of them.

    Change the sparkplugs again just to be safe.

    Shawn

  7. #7
    another 80 dollars for plugs,thanks for the tips

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,359
    +1
    975
    Quote Originally Posted by miassmaro98 View Post
    another 80 dollars for plugs,thanks for the tips
    Buy the plugs at Advanced Auto parts.....about $10 each. Order NGK stock # 6544.

  9. #9

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got a problem with my 2013 VXR
    By ramstein in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 06-09-2014, 09:20 AM
  2. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM
  3. OMG Problem with my rxp and myself!!!!
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2006, 09:55 AM
  4. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •