Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1

    02 Polaris Virage I stops intermittently.

    Please help!!!!
    My jetski ( Polaris 2002 Virage I ) stops intermittently while using. Sometimes I can start it right back again and sometimes it doesn't crank but I hear a click noise similar to when trying to start the jetski while battery is low. Battery power seems to be ok. Last time when engin stops, the battery was at 14v.
    This problem started after following issue. Last month I had a problem with my jetski. With everyone help from this forum, I found that my bendix gear ripped and the ripped gear broke flywheel's magnet and damaged my stator.
    I replace the stator with used stator, new flywheel and bendix. I put everything back together as per service manual.
    Now my jetski is stopping intermittently and not sure why.

    Please help!!!!
    Thanks for your time.

    Kevin


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Sounds like maybe your losing a ground at times,Check all the connections and clean them.Does it restart after cooling down?

  3. #3
    Yes, it does.

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Normally heat related problems are related to electrical failures of a component. Since I'm not up to date(and never been) with the Fitch systems,someone else will have to go from here. When K447 gets a chance he can add insite,he currently has 2 and has studied them greatly(plus he's electriclly smart)I'm just SMRT.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Install a fuel pressure gauge and see if you lose pressure before it dies.

  6. #6
    Here is what I did. I put new battries, make sure all the connection is good. I also clean with elec connection cleaner to make sure all the elec contacts are good. Such as spark plugs connections, stator connection to the control unit, battery connections, cps connections and a few other connections.

    Now my jetski will go about 1 miles and rpm starts to drop from 5.5K to 4 to 3 to 2 then dies. Had to wait about 4-5 minutes then I can restart.

    Not sure how to connect fuel pressure guage and where can I get the guage?

    Thanks you so much for the help!
    Kevin

  7. #7
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    You can buy a gage at O'Riellys or about any auto parts store for about 25.00.

  8. #8
    Ok, what number should I check for the pressure?

    I changed the spark plugs and try to run it at 3K rpm for about 15 minutes at natural gear and it seems ok. But idle was rough and engine dies at idle speed. I notice that rpm is not steady state and it goes up and down between 800rpm to 1000 rpm then quits.

    I made it worst by trying to adjust the idle and now top speed is about 30 miles / 5000 rpm. It used to goes between 45-50 or 6000 rpm.

    How can I adjust the idle back to normal? Please help!!!

    Thanks
    Kevin

  9. #9
    I found a few entries with idle problem in this forum. K447 was helping out a guy with his idle problem. I was using autolite spark plug. Hopefully NGK PZFR6H spark plug will take care of idle problem.

    I bought this jetski used and the original owner was using autolite spark plug and I was using the same for a while. I didn't have the idle problem until I had to fix the bendix issue I had a month ago. Did I damage my jetski by using sutolite spark plug?

    I really mess-up my jestski idle adjustments by adjusting Oil pump adjustment, idle speed and throllel lever without knowing their function. I guess this is what heppened when you know nothing about jetski and try to work on it. Hopefully I can adjust back to normal position base on the service manual so I can get back to my original issue.

    Thanks
    Kevin

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by jitan2004 View Post
    Ok, what number should I check for the pressure?

    I changed the spark plugs and try to run it at 3K rpm for about 15 minutes at natural gear and it seems ok. But idle was rough and engine dies at idle speed. I notice that rpm is not steady state and it goes up and down between 800rpm to 1000 rpm then quits.

    I made it worst by trying to adjust the idle and now top speed is about 30 miles / 5000 rpm. It used to goes between 45-50 or 6000 rpm.

    How can I adjust the idle back to normal?...
    What did you adjust to change the idle speed?

    On a Ficht engine, the EMM computer controls the idle, and the engine should idle at a solid 1100-1150RPM, give or take just a little.

    Make sure the throttle cable adjustment is set to allow just a tiny amount of slack before the throttle shaft on the engine starts to rotate.

    There are several possible contributors to your problem, so some checks and tests will narrow down the possibilities.

    The fuel pressure needs to be above 20PSI, and should be essentially constant while the engine is running. You can take the Brown wire from the fuel pump connection, and short that Brown wire to ground, the fuel pump will run, and you can check the fuel pressure without running the engine.

    When the problem occurs, you need to confirm that you still have proper fuel pressure.

    Once you have set the throttle cable correctly, unplug the TPS connector at the rear end of the throttle body, and report back whether the idle settles down to a steady RPM.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Polaris Virage I stops intermittently
    By ChesapeakeBayRunner in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-20-2009, 12:52 AM
  2. 02 Polaris Virage 700 carb adjustment
    By sirdave4 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-30-2009, 06:11 PM
  3. 02 Polaris Virage
    By gusie1 in forum Polaris Skis
    Replies: 6
    Last Post: 09-09-2008, 07:59 PM
  4. 02 Polaris Virage cranks but won't start
    By ktts65 in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 08-01-2008, 09:49 AM
  5. 02 Polaris Virage TXI Burnt piston after 12 hrs?
    By svtfan in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-15-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •