Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Prop Spin???

  1. #1
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28

    Exclamation Prop Spin???

    I am getting prop spin on take off and during tight turns. Should I re-pitch my impeller differant?? I am getting 7140 for RPM's..I think I need a little more but cannot stand the spin....Any Ideas???


  2. #2
    yami_rida#26's Avatar
    Join Date
    Oct 2007
    Location
    Cayman Islands
    Posts
    2,112
    Quote Originally Posted by Ramps View Post
    I am getting prop spin on take off and during tight turns. Should I re-pitch my impeller differant?? I am getting 7140 for RPM's..I think I need a little more but cannot stand the spin....Any Ideas???
    Not sure what size pump exit nozzle comes on the 1200's but if it's an 85 mm maybe try an 87 mm to bring the rpm's down and pick up some holeshot.

  3. #3
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174
    Hi,Did this just start after a mod?If not check wear ring clearance!>scott

  4. #4
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28
    Hey,
    Thanks for quick reply...I have the metal 08 SHO pump, I think it is 87 mm.

  5. #5
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28
    Brand new wear ring when 13/19 installed...I think the spinning started after I got my carbs dialed in pretty close and my power valves where they should be...I am stumped...

  6. #6
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28
    yeah more water through better hole shot..I think a 14/20 would be better if I can turn it without problem..Can I repitch my 13/19 solas??

  7. #7
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    649
    +1
    28

    Exclamation Come on guys...

    Need some answers please....

  8. #8

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Sounds like cavitation to me but why it manifested itself after your carb rejet is beyond me. I was suffering from it really badly before my PPK and sealing everything up.

  9. #9
    Hey - not hijacking, but also having a problem and I don't know what "prop spin" means. Anybody?

  10. #10
    Ramps, w/your mods, you've definately flowed your motor to where it's gonna be quicker out of the hole thus more prone to cavitation, but one thing you don't have listed is the 1200 grate(?). This really helped me down low cause it kept my pump loaded with water and thus the loaded the motor and hooked-up the prop.

    Ops, sorry, it looks like you've got a grate.....

    Jimbob

    06 1300 modified stage 2

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. prop spin on take off..plz help
    By al_osman in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-03-2010, 04:47 PM
  2. massavis Prop Spin
    By k-man-kid in forum 4-Tec Performance
    Replies: 22
    Last Post: 04-23-2009, 12:33 AM
  3. prop spins out of the hole,help!
    By jamiej in forum 4-Tec Performance
    Replies: 15
    Last Post: 11-24-2008, 09:54 AM
  4. Prop Spin/Cavitation Issues Resolved.
    By ba6636 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-20-2008, 06:40 PM
  5. Prop Spin??
    By Ramps in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 05-23-2008, 06:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •