Results 1 to 6 of 6
  1. #1
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1

    1995 Slt750 Guage Not Working

    Hello, see if any of you great polaris goroos can help me out. My guage is acting crazy the fuel side goes all the way up and then comes down and shows empty, the clock works but you can not set the correct time, speed does not work, sometimes it will display :LOOPS: at the bottom. Is this the guage itself that is bad or do I need to look for another problem . Thanks for any help!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275

    MFD display reset


  3. #3
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1

    Cool

    THANKS for all the info and the down load. I will try this tonight and let you know what happens. I love the forum and my POLARIS 750. I just bought a triple pump from John Zigler and he had a handlebar pad I was looking for. Alot of good people on this forum !!!!!!!!!

  4. #4
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Hello K447, reset sequence worked! Everything is working now except the fuel bars on the left side, shows three bars at the empty mark. Think mabe a sending unit or stuck float? Thanks for your help. Hey I was thinking about buying a set of over size pistons and having the juggs bored for more power. Then I emailed a guy on ebay about some stock heads and piston off a 780 he had up for auction. He told me that they would work but I would need to change the exhust manifold too. Said it would give about 15 more hp. Would you know if this is true? I bought this off a lady and it is in perfect shape. Motor was replaced last year. Also would I gain anything with a performance grate. Any advise would be great.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by OLDJETSKIMAN View Post
    ...reset sequence worked!
    Everything is working now except the fuel bars on the left side, shows three bars at the empty mark.
    Think maybe a sending unit or stuck float? ...
    The MFD shows 3 bars when you know the tank is empty?

    It is possible the fuel pick-up hose in the tank is broken, and not reaching the bottom of the tank. Or the fuel sender is not working properly.

    Either way, you should pull the fuel tank unit out and check it over. If you have never replaced those 13 year old fuel lines, now would be a good time, including those inside the tank.

  6. #6
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Sorry I should have been more detailed, the tank is full and shows only three bars at empty. The triple pump I bought should be here this week and I will plan on replacing all the lines and checking the sending unit. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WTB- Guage Cluster- working or not 04GTX
    By Piney in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 08-25-2012, 09:22 AM
  2. SLT 750 fuel guage not working
    By moto-m in forum Polaris PWC Performance
    Replies: 11
    Last Post: 07-01-2012, 08:51 AM
  3. trim/guages not working
    By rickg2756 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 05-12-2011, 06:52 PM
  4. Gas guage not working 95 SPX
    By CrazyClam in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-26-2008, 09:16 PM
  5. '95 Polaris SLT750 MFD Gauge Not Working
    By cubsfan2516 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 04-22-2008, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •