Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174

    Pop Goes the PTO!!!!

    The PTO piston pooped out at 100.1 hrs.

    I know the ring grabbed the exhaust port but why?
    -and what horse-shoe part trashed the head/piston?
    -and where are those parts now?

    It's been ~30 hrs (flawless hours) since the last adjustment.

    pics are after I limped back to the launch (~.25 mile).
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	a1.jpg 
Views:	132 
Size:	207.8 KB 
ID:	96369   Click image for larger version. 

Name:	a2.jpg 
Views:	168 
Size:	215.2 KB 
ID:	96370  


  2. #2
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    close ups...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	a3.jpg 
Views:	88 
Size:	142.1 KB 
ID:	96371   Click image for larger version. 

Name:	a4.jpg 
Views:	76 
Size:	100.5 KB 
ID:	96372   Click image for larger version. 

Name:	a5.jpg 
Views:	89 
Size:	192.0 KB 
ID:	96373  

  3. #3
    As long as cyl is good, you'll be alright, have 2 used pistons and rings, approx 40hrs, still look good, you'll need a head to, also have that........

  4. #4
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    could be ring... could be crank....

    Pull the piston and out the rest of the story.

  5. #5
    I looked better at the pic, I have 3 nice cyls...........

  6. #6
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by Hydrotoys View Post
    could be ring... could be crank....

    Pull the piston and out the rest of the story.
    There's the rub. I have an extended warrenty so I'll have them give it a go after swapping reeds and efi.

  7. #7
    Quote Originally Posted by steach View Post
    There's the rub. I have an extended warrenty so I'll have them give it a go after swapping reeds and efi.
    Doh! dontcha think they`ll be able to tell it was apart?

  8. #8
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by Pale Rider View Post
    Doh! dontcha think they`ll be able to tell it was apart?
    Not if you are good about putting everything back correctly... I have seen about 5 of the non-pvs this year that have spun the ring and hooked the port. 2 of them were not stock (and each a little over 100 hours) and the customers had extended warranties. I put them back to stock and the dealers fixed them for free ! One got 3 new pistons and a new cylinder and the other got a whole new motor !

  9. #9
    5 ski`s , that`s not good...

  10. #10
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by WFO View Post
    Not if you are good about putting everything back correctly... !
    Update:
    -I got an unmodified pipe & cat ~$100 due to jetworx mod. (thanx Crashhard)
    -Removed race air-box and VF3s and reassembled to 100% stock using Loctite 572. (hard to find but Fastenal got it for me) (50ml may be overkill)
    -Reinstalled head using 572 and proper torques.
    -Removed plumbing for JW mod and capped the bilge siphon line. (no pipe in nozel)
    -Intalled stock strainer cover and ride plate/grate.

    Items left: (any problem?)
    -Riva FF exhaust tube.
    -After market handle bars/grips.
    -CF tunnel re-enforcment.
    -Amsoil Interceptor injected.

    To Do:
    -Greece the service manager ~$50 and hope for the best! (he gets to charge for the throt cable recall at the same time)

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. POP Goes the 09 RXT-IS
    By bluesun in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-30-2012, 05:45 PM
  2. POP goes the cooler!!
    By RichieFZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 22
    Last Post: 03-24-2011, 05:04 AM
  3. Snap goes the pump stud!
    By whit33 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-01-2007, 12:45 AM
  4. Moranic Mistake - Down goes the 1200XLL - Need some thoughts!
    By snowrunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-28-2007, 08:27 PM
  5. im trying to find the seal that is in the pto cover
    By rapidacceleration in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-25-2006, 11:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •