Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393

    GP760 Weirdness....

    I have noticed something on my GP760 that I think is rather alraming, but I could be wrong:

    There is oil/gas being sprayed back out of the airbox, and also all over the carbs there is oil residue. It is not as bad since I converted to premix. (Not like a fire hose, just a fine mist)

    I have also noticed when on the trailer, and running, when you blast the throttle wide open, you can see all kinds of fuel/oil trying to spray up, and out... This is really hard to explain. You have to see it to understand what I mean.

    As far as performance, it doesn't seem to be hurting any. It pulls up to, and will hold 6,800 RPM (According to the factory tach). It runs around 50mph, or so (GPS), which is what I am guessing they normally run.

    Could I be having a reed problem? Or is this a normal thing for this engine?


  2. #2
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393
    One thing I forgot to add: You shouldn't be able to see fuel mist above the venturi, correct?

  3. #3
    improvised tmg97gp's Avatar
    Join Date
    Jul 2008
    Location
    Midlothian Virginia USA ~ On the James River~
    Posts
    1,377
    +1
    10
    My GP1200 does the samething.

  4. #4
    it is the job of the reed valves to stop the air fuel mix from going out thru the carbs! I would def check their condition! ( a little blow back happens do to reaction time of the reeds

  5. #5
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393
    it is the job of the reed valves to stop the air fuel mix from going out thru the carbs! I would def check their condition! ( a little blow back happens do to reaction time of the reeds



    That's what I was kind of thinking.. I mean there isn't a TON of oil everywhere. It's just "noticable".

  6. #6
    well if it's running fine don't tear it apart just to check! wait till you do your routine carb inspection and just dig a little deeper and pull the reeds! weren't u thinking about a reed spacer?

  7. #7
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393
    Yes, I am definitely thinking about that. Riva also has VF2's for the 760. It's a shame they aren't VF3's, but it should be a definite improvement.

  8. #8
    RonJon's Avatar
    Join Date
    Sep 2007
    Location
    Sarasota, FL
    Posts
    364
    +1
    31
    Hey a little off topic, but I know that the GP800 is 120hp and will do 58-59 out of the box... But what is the hp of the GP760?

    My 2000 GP800 did the same thing. It looks like fog that tries to escape the carb opening for a split second, but is then quickly sucked back in. Did it since I got it new... It ran great and never stranded me.

  9. #9
    Here come the smokers! OBXJeepGuy's Avatar
    Join Date
    Aug 2008
    Location
    Outer Banks, NC
    Posts
    1,393
    Quote Originally Posted by RonJon View Post
    Hey a little off topic, but I know that the GP800 is 120hp and will do 58-59 out of the box... But what is the hp of the GP760?
    A whopping 90 horsepower. It's funny how they squeezed 30 hp out of less than 50cc.

  10. #10
    I found a spacer on ebay for 20$ and if u want to save some coin? I run carbon techs in most of my rides ( decent reed at a good price )

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Friday the 13th a lil weird for me
    By 01xdime in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 01-17-2006, 12:28 AM
  2. THATS WEIRD
    By peteshauling in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 01-06-2006, 05:42 AM
  3. GPR making some weird noise
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 12-26-2005, 05:55 PM
  4. a bit of a weird problem, can I have opinions please???
    By rxp_boy in forum 4-Tec Performance
    Replies: 9
    Last Post: 11-15-2005, 01:39 PM
  5. waverunner gp760 gauges
    By frebird75 in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 09-04-2005, 01:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •