Results 1 to 5 of 5
  1. #1
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61

    oil buildup where my rotary valve is

    Is this weird or common? Took my rotary valve cofver off and pooled on the inside of the bottom of the cover was oil. Im assuming oil shouldnt be there? the oil injection is being removed as we speak, so i guess i dont have to worry about this anymore, but could be a good reason why it smoked like hell on initial startup?


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Most likely culprit is the Rotary valve shaft seal is leaking. If you still have the cover off, soak up all the excess oil with a paper towel, especially around the gear. It will puddle up and drip down the face if the seal is bad. You can also pressurize this cavity up to 6 PSI to confirm the seal is leaking.

    Very seldom do the oil injection nozzles fail open.

    Also try to move the RV gear side to side to see if the bearing is failing. There should be no lateral play. If so, this is why the seal has failed.

  3. #3
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    there was none around the gear. I did put the new cover back on but can always take it off again. I also noticed oil coming out of the nozzle on the injection pump itself, thats why i kinda went towards that. If i ignore this for the time being (since the season is almost over) Do you think ill have a problem?

  4. #4
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    What motor ??

  5. #5
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    787, sorry should have put that in here

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 04-04-2014, 09:18 AM
  2. oil coming out of my rave valves
    By kahlescbc in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-07-2010, 08:22 PM
  3. I can't find where my Genesis is leaking
    By Budman in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-20-2010, 10:55 PM
  4. rotary valve oil line busted. engine ran around lake for 20 min...
    By djpeetur in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-07-2010, 09:53 AM
  5. Where my large water leak is?
    By camar0 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-19-2009, 03:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •