Results 1 to 3 of 3
  1. #1

    Join Date
    Aug 2008
    nverness, FL

    2000 GP1200R cavitate

    i just got this ski about a week ago. i noticed when going from stand still to WOT it would feel very slugish or cavitate some i had a 98 gp 1200 and never had this problem is there a diffrence in the pumps? i just seems like the ski isnt as responsive as id like. what to do to help??

  2. #2
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    The Rock
    have you checked the conditon of the prop

    also while your there check the gap between prop and ring,see user manual for specs

  3. #3

    Join Date
    Aug 2008
    nverness, FL
    well the prop looks like new no nicks dings or anything. i got the ski a little over a week ago the guy before me had new wear ring and new impeller(STOCK) put on. or at least he claims. it looks all new. there isnt much of a gap between wear ring and impeller..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermediate shaft from 2000 gp1200r
    By wademcgee in forum Yamaha Classifieds
    Replies: 1
    Last Post: 06-24-2008, 08:14 PM
  2. Advice needed... buying a 2000 gp1200r...
    By jcc011185 in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 07-13-2007, 04:36 PM
  3. 2000 gp1200r
    By TX21 in forum Yamaha How To & FAQs
    Replies: 14
    Last Post: 05-22-2007, 08:22 AM
  4. Price help on a 2000 GP1200R
    By flnsx in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 05-15-2007, 05:30 PM
  5. I need an oil pump for 2000 GP1200R
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-29-2007, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts