Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38

Thread: Broken Valve

  1. #1

    Broken Valve

    I'm wondering if anybody had this problem before!! I took my jet to the lake last week for my second ride with stage 3 and this happend
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1.JPG 
Views:	84 
Size:	143.0 KB 
ID:	97029   Click image for larger version. 

Name:	2.JPG 
Views:	56 
Size:	141.9 KB 
ID:	97030   Click image for larger version. 

Name:	3.JPG 
Views:	61 
Size:	147.7 KB 
ID:	97031   Click image for larger version. 

Name:	4.JPG 
Views:	49 
Size:	155.2 KB 
ID:	97032   Click image for larger version. 

Name:	5.JPG 
Views:	55 
Size:	142.4 KB 
ID:	97033   Click image for larger version. 

Name:	6.JPG 
Views:	43 
Size:	137.2 KB 
ID:	97034  

    Click image for larger version. 

Name:	7.JPG 
Views:	50 
Size:	137.0 KB 
ID:	97035  


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    DANG!

    What year ski?

  3. #3
    Same thing happened to me 04 RXP. I heard the 04-05 215's had this problem, but from 2006-up they do not. Anyhow, sorry about your luck. Dont just throw a new head on there, tear the whole motor apart. Mine had metal fragments everywhere. It ended up needing a new crank too.

  4. #4

    Valve

    Kohl So this it's nothing to do with the mods I did? this will happend anyway with this jetski?

  5. #5

    VALVE

    I´ve Seen Broken Valves Like Yours Caused By Rusty...this Happens When The Skis Are Long Time Stopped
    Sorry For Your Damaged Engine

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by douglasb76 View Post
    Kohl So this it's nothing to do with the mods I did? this will happend anyway with this jetski?
    Nope, i have seen this happen on bone stock skis.
    What year is your ski? The 04-05's were real prone to this happening.

  7. #7

    My

    My It's a 04 RXP
    Jerry do you think If I buy the ferrea Valve and Riva valve train will be Ok?

    I have to check the connecting rod for any damage

  8. #8

    Exclamation help

    I need some suggestions about this problem !
    All tips are welcome

  9. #9
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    After you get it broken down and cleamed up make sure you replace the flywheel bolts.

  10. #10

    Join Date
    Jun 2005
    Location
    rome ga
    Posts
    938
    +1
    20
    If you have time check the crank first.
    Get solid exhaust valves at least use ,08 rxpx SeaDoo valves.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BROKEN VALVE.. Parts?????
    By Octaneauto in forum 4-Tec Performance
    Replies: 32
    Last Post: 09-01-2010, 09:45 PM
  2. Broken Valve Springs
    By thompsdw in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-09-2009, 09:48 PM
  3. does broken valve mean blown motor??
    By braaapf7 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-11-2009, 09:32 AM
  4. Broken Valve
    By douglasb76 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 10-01-2008, 07:05 AM
  5. Please Help!! Broken valves...
    By Ramps in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 04-13-2008, 01:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •