Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61

    Exclamation Seadoo RXP issues

    Hey I just recently got an 04 RXP and have had a few problems with it on the weekend, and being a newbie i have no idea what could possibly be wrong with it..

    The ski is very jumpy in its rev's, kind of like a jolty feeling and at times i would lose alot of power, then it would kick in all of a sudden by itself and go hard, but still only reaching 55 mph and about 6k rpm..

    but if i just take it easy the engine sounds like im constantly changing the throttle, which im not.. i was holding it steady.

    but after we dropped the revs down and went to pick back up again, there was no power, didnt matter how hard i would push the throttle the engine wouldnt kick in again.. i could get to 4k revs and that was about it..

    and from a stand still take off the engine would do alot of work, and we wouldnt really get anywhere... when it should be flying out of the water..

    at first we thought it might be a blockage in the fuel... but reading up more seems there might be a problem with my S/C? Although i could hear it whining when we were maxing out at 6k rpm...

    dosnt look good from what im seeing
    and to make matter worse.. i just fkn bought it =/

    its got about stage 1.5 done on it..
    thinking about taking it to dealer... guna cost me an arm and a leg?


  2. #2
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Don't take it to the dealer. We will get you through it. The RXP is the platform that members have the most experience. I, for one, am not an RXP owner. Others will post, give them a little while.

    Look in the intake grate under the ski and look at the impeller blades, make sure they are sharp and not bent up, like they have sucked in some rocks. Also look at the wear ring that wraps the impeller to make sure there are no gouges or sever wear from the impeller spinning. All these cause cavitation. Use the "search" function and read.

    Also, if you don't know already, You need to learn the parts of the ski and their locations. With a Stage 1+, I am assuming the previous owner knew to change the SC (supercharger) washers. If I were you, I would not assume and I would verify they were swapped out for the newer metal washers.

    From sitting in the water and giving WOT (wide open throttle) and the ski not going anywhere sounds like severe cavitation. On the top end it sounds like cavitation OR boost leak. 55 MPH and 6000 RPMS sounds like SC slipping. Wait for the more experienced members to post. They can probably help you more.

    That should give you a start though. By the way. Do not use the display for speed. Get you a hand-held GPS for exact speeds. All members posting here are posting their GPS speeds, not display speeds from the "wishomoter" (speedometer)

    Welcome to the forum. --jeremy

  3. #3
    Also check oil level carefully...my RXT acted very similar the one time it was overfilled. You REALLY dont want ore than halfway up dipstick when perfectly level (check side rails of when in water)

    oil change and new plugs later mine was perfect.

    Does it have new Supercharger washers?

  4. #4

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    if your rpm's are maxing out at 6k and your max speed is 50mph then I would not run that machine any further. Take the SC off and look at it. Sounds like SC failure to me. The RPM and speed numbers you mention are very reflective of washer failure. If you keep running it you will just cause more damage.

  5. #5
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,798
    Welcome to the forums.
    Read this:
    http://greenhulk.net/forums/showthread.php?t=19887

  6. #6
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    I'd say supercharger failure. Next thing you need to do is invest in a repair manual. It is very detailed, has pics, and will get any new owner on the right track to doing what needs to be done. Also, post where you are from. Ya never know, there might be a forum member right around the corner who can get you up and running.

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Look in the Sea Doo General section for links to online manuals. Then post if you can't find them... Ron

  8. #8
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61
    Hey thanks,

    Yes i've been reading about the S/C washer problem, but i would think that the guy who had it prior to me would have changed it... afterall.. he did all the mods himself etc.

    I'm going to go and have a look at the grate and impeller wear ring and see what i can find..

    I'm in Melbourne, Aust..
    But yeh, dont know alot about these things.. so you dont think i should go to the dealer?
    Ohh and with the manual, i got the owners and service manual.. is there a repair one as well?

  9. #9
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    could be plugs or a coil gone bad.a lot of dealers don't grease under the top of the coil seal and water gets in then rusts out the coil. this can either just kill the coil or sometimes make it work then stop then work etc. or it could just be the washers as usual. take it to seadoo center if it gets to tricky, they will look after you.

  10. #10
    Benazz's Avatar
    Join Date
    Sep 2008
    Location
    Vic, Australia
    Posts
    61
    mm, checked the grate, was fine.. one thing i did observe when we pulled it out the other day was a bit of fuel coming out of the exhaust pipe...

    thats not normal is it? :/

    might try and get a look at the SC, if it spins freely its stuffed yeh? :P

    booked in at dealer in 2 an a half weeks, hopefully they can sort it out for me.. the guy said i should have my ski back by the afternoon (getting it there at 8:30) seems pretty quick :O

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SeaDoo RXP 255 Starting issue...
    By rbhamilton in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-29-2016, 11:26 AM
  2. Seadoo RXP Issue?
    By SeaDoo23 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-25-2016, 07:56 PM
  3. 2005 Seadoo RXP Starting issue
    By njbd1988 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-28-2013, 09:23 AM
  4. 2006 Seadoo RXP Coolant Issue
    By anbeeson in forum 4-Tec Performance
    Replies: 14
    Last Post: 09-24-2011, 02:59 AM
  5. Seadoo RXP Stupid Computer Issue
    By seadooct in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-21-2010, 03:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •