Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21

Thread: erratic rpms

  1. #1
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6

    erratic rpms

    Went out for a ride yesterday with Delgado and I was on the limiter early in the ride due to cool weather. After a few speed runs pulling 8550 my rpms gradually started to decline. I assumed this was normal heat fade, but soon the rpms were all over the place 8150 to 8350 varying up and down with WOT or 3/4 throttle.
    What could the rpm loss be? A respected tuner told me to check the Intercooler (RIVA GEN1) and the throttle cable. I checked the pump, prop, grate, rideplate, hull, etc. after the ride with nothing abnormal. The boost levels put out were appropriate at the rpms so the SC was not slipping.
    any input?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Doug, you say the boost levels were appropriate for the RPM's. Do you mean the boost would drop when the RPM's dropped?

    I highly suspect a slipping clutch. This is exactly what a clutch feels like when slipping at high RPM's. Surging in and out.....

  3. #3
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Quote Originally Posted by Green Hulk View Post
    Doug, you say the boost levels were appropriate for the RPM's. Do you mean the boost would drop when the RPM's dropped?

    I highly suspect a slipping clutch. This is exactly what a clutch feels like when slipping at high RPM's. Surging in and out.....
    I mean when the ski was turning 8100 it was 12ish psi at 8350 it was around 12.5 psi. I will check the slip this week.
    I have wanted to update with the 08 kit so I guess i will go ahead and do that
    I will pressure test the IC tomorrow.
    COuld a TPS cause anything like this? I have noticed in the last few weeks that my motor takes a few seconds to longer than it used to come down to 1750-1850 rpms when coming off the throttle
    any other thoughts

  4. #4
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Doug...











    ....................................its your hair.

  5. #5
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Quote Originally Posted by Danny View Post
    Doug...











    ....................................its your hair.

    you guys are just jealous of my donald trump hairdoo
    a little help here please

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Doug, the 08 kit is the way to go. I think this will solve you issue.

  7. #7
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Quote Originally Posted by Green Hulk View Post
    Doug, the 08 kit is the way to go. I think this will solve you issue.
    darn it. ok, sign me up for an 08 kit

  8. #8
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by dhoad View Post
    you guys are just jealous of my donald trump hairdoo
    a little help here please


    With the wind resistance that thing generates, I'm surprised you still stayed on the seat!


    The 08 kit should help, but if it starts out strong and then tappers off, you got slippage. At the labor day ride I was okay, then all of a sudden I lost 500 rpm...Snoman checked my slippage, I was in the 60's

  9. #9
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    Quote Originally Posted by Danny View Post
    With the wind resistance that thing generates, I'm surprised you still stayed on the seat!


    The 08 kit should help, but if it starts out strong and then tappers off, you got slippage. At the labor day ride I was okay, then all of a sudden I lost 500 rpm...Snoman checked my slippage, I was in the 60's
    hahahaha, you guys are just jealous cause I still have a full head of hair. The brain cells are dying but the hair just keeps growing
    yyup, started strong rippin off 8550 rpms and it faded, I guess I need to learn to come off the throttle in the rough stuff. Juan made me ride fast , its all his fault
    Fargin SC
    I am going turbo gosh darn it.

  10. #10
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by dhoad View Post
    Fargin SC
    I am going turbo gosh darn it.


    Thats what I said over the winter....and it is still sitting in my basement

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Erratic RPMS
    By Av8tordude in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-26-2015, 02:42 PM
  2. erratic RPM Polaris Hurricane
    By z71jason in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-07-2012, 08:34 PM
  3. RXP Erratic RPM
    By Roger in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-23-2010, 07:04 PM
  4. 2004 GTX Limited Erratic RPMs
    By richte18 in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-28-2009, 04:13 PM
  5. Erratic RPM Reading
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-23-2008, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •