Results 1 to 6 of 6
  1. #1

    GTX SC power loss

    Hello,
    I'm new at the site and look forward to getting some good info from you guys. Ive got an 04 GTX SC and when I put the key in there are the normal 2 beeps then I start it, take off and everything is fine for about 5 seconds then there is a long beep and it looses more than half of it power. I made sure there was enough fluids and everything was tighten. Any advice? Thanks


  2. #2
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    It is going into LIMP mode. Don't know why for sure.
    You need to look at the display when it happens. You
    may get a better clue of what's going on. It is probably
    something simple like an oil sensor or a bad tops sensor.
    We'll need more info though

  3. #3
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by GTXsupachargd View Post
    Hello,
    I'm new at the site and look forward to getting some good info from you guys. Ive got an 04 GTX SC and when I put the key in there are the normal 2 beeps then I start it, take off and everything is fine for about 5 seconds then there is a long beep and it looses more than half of it power. I made sure there was enough fluids and everything was tighten. Any advice? Thanks
    Check your pump, make sure there's nothing caught up in there restricting the water flow.. Did you get a chance to read the code that flashed after the long beep?

  4. #4

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    04 Had Problems With Oil Pressure Sending Units.please Try To Get A Code For Us.when Ski Goes Into Limp Mode Donot Cut Engine Off And Press Mode Buttom 5 Times And See What Code You Get.todd

  5. #5
    I just went and checked and I dont get any codes when I push the mode button 5 times. I noticed there was water in my gauges a couple days ago and today they are acting up(going on and off). I know thats an issue, but would it keep the ski from its full power?

  6. #6
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by GTXsupachargd View Post
    I just went and checked and I dont get any codes when I push the mode button 5 times. I noticed there was water in my gauges a couple days ago and today they are acting up(going on and off). I know thats an issue, but would it keep the ski from its full power?

    I don't think the two would be related.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 06-22-2017, 07:57 PM
  2. FS Riva RXP-X/RXT-X/RXP/RXT/GTX-SC Power Filter Kit
    By kenshin89 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-17-2010, 07:52 PM
  3. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:32 PM
  4. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:16 PM
  5. 2003 gtx sc intermittent loss of no 2 cylinder
    By csurt in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-13-2008, 06:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •