Results 1 to 9 of 9
  1. #1

    Cat removed, D-Plate installed.. Warning Alarm going off!!!

    hey guys,

    A few weeks ago I had trouble with the exhaust warning light going off...
    Cat was screwed!!!! Fallen to bits..

    Replaced it with a Riva d-Plate, fully cleaned out all debrie..
    I got it done at a mechanics.

    The following weekend i took it out for the first time and after about 20mins the alarm came on again.. I was Pissed!!!
    So i took it back for them to look at it...

    They said it could be a faulty sensor??

    Does anyone have any suggestions for me plz!???????

    The mechanic also said not to put in the cat temp sensor chip cause they have had more prblems with them in...

    Should i put the chip in?? Is it easy??

    Any suggestions plz.....

    Cheers


  2. #2

    Join Date
    Jul 2008
    Location
    cape cod
    Posts
    195
    you need to put the chip in, thats why it is alarming

  3. #3
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    What year ski?

  4. #4
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    Quote Originally Posted by OsideBill View Post
    What year ski?
    this is why bill is asking what year,see link if 05 or above
    http://www.greenhulk.net/forums/show...highlight=chip

  5. #5
    Hey, I'm Joel's brother.

    It is a 2004 model. From reading the post mentioned above, I'm pretty sure we will fix the problem by installing the Riva chip. Can you confirm, given it is a '04 model, we won't need to also install a 2.2k ohm resistor?

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    I believe the chip will work on the 04 motor.

  7. #7
    fenn's Avatar
    Join Date
    Jan 2007
    Location
    Exit 98, New Jersey
    Posts
    926
    +1
    1
    if its an 04 you just need the chip.

    buy the chip and the beeping will stop.

    i have an 04 and i use the chip and haven't had any problems

  8. #8
    Hey fenn,

    Cool man thanks...

    What seat is that??? Where ya get it??
    Im in australia. melbourne and want a new seat and dont know where to get it??

    cheers mate

  9. #9
    fenn's Avatar
    Join Date
    Jan 2007
    Location
    Exit 98, New Jersey
    Posts
    926
    +1
    1
    its a custom seat by M-line. I used the style of one they offered but got rid of some white and replaced it with silver

    here's there ebay store.. there a small company, great people

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. removed cat/con...d plate installed YAY!
    By phumb in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-13-2011, 06:23 AM
  2. Cat temp alarm going off even after installing D-plate
    By yamadood in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 03-04-2011, 09:09 PM
  3. Warning alarm going off?
    By mcrowe in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-31-2010, 06:09 PM
  4. All alarms going off on my Honda F12
    By bhenschel in forum Honda Performance
    Replies: 0
    Last Post: 08-24-2009, 01:40 PM
  5. 01 GP1200R Alarm going off
    By smace in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 02-05-2008, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •