Results 1 to 6 of 6
  1. #1
    Dixieboy Dixieboy's Avatar
    Join Date
    Jan 2008
    Location
    Millington, Tn
    Posts
    62
    +1
    1

    no fuel indication

    Guys , My fuel indicator went blank or to zero saturday from home to the lake.(1997 GTX) Had a full tank and good reading when I left home and when got the lake no reading at all. Everything else worked fine. I get no bars when connecting lanyard. Tried to check ohms from sending unit wires with a 1/2 tank and get no reading. Anything else to check before I dive into the fuse replacement in the float assembly? I read the threads about replacing the fuse which were great. Thanks for any help. Me and electrical gremlins are not the best friends. I did the paper clip test and get full bars.


  2. #2
    fireball451's Avatar
    Join Date
    Jun 2008
    Location
    Gray, TN
    Posts
    62
    From the research I have done, it sounds to be the fuse,
    I have the same problem, but have not did the fuse replacement yet. The opportunities I have to work on it, I usually wind up going to the lake. I have decided to wait on doing the repair until lake weather is totally gone here. It could be your float if it has not been replaced. I would go ahead and do both while you have the baffle out since both are very common problems.

  3. #3
    Dixieboy Dixieboy's Avatar
    Join Date
    Jan 2008
    Location
    Millington, Tn
    Posts
    62
    +1
    1
    Fireball, Thanks for the tips. I too am waiting till season end which will be soon to do the fuse. I have to admit I haven't changed the tempo fuel lines on my 97 GTX. I will change all when I do the fuse and check the float but it's been bullet proof so far. My 98 GTX lmtd has had the hoses changed. Where's Gray ,Tn? I'm in Millington outside of Memphis. I picked up my 98 limited last year for $1500 and love it. Had any problems with your 951? Mine has the gasket updates and aftermarket air filters. 65 mph on the speedo which I know is overstated. Thanks.

  4. #4

  5. #5
    Dixieboy Dixieboy's Avatar
    Join Date
    Jan 2008
    Location
    Millington, Tn
    Posts
    62
    +1
    1
    Thanks 951. those are great.

  6. #6
    fireball451's Avatar
    Join Date
    Jun 2008
    Location
    Gray, TN
    Posts
    62
    Quote Originally Posted by Dixieboy View Post
    Fireball, Thanks for the tips. I too am waiting till season end which will be soon to do the fuse. I have to admit I haven't changed the tempo fuel lines on my 97 GTX. I will change all when I do the fuse and check the float but it's been bullet proof so far. My 98 GTX lmtd has had the hoses changed. Where's Gray ,Tn? I'm in Millington outside of Memphis. I picked up my 98 limited last year for $1500 and love it. Had any problems with your 951? Mine has the gasket updates and aftermarket air filters. 65 mph on the speedo which I know is overstated. Thanks.
    Gray is just outside (but quickly becoming part of) Johnson City.
    You need to get those lines changed.
    Mine were terrible.
    I purchased mine with a fresh motor.
    It seized up about the 5th outing.
    I pulled the head and the mag side had seized, but the pto side was perfect.
    I have suspected something to do with the oil injection caused it. Maybe a restricted line.
    Probably why the motor had to be redone in the first place.
    Put a SBT motor in, changed to pre-mix, and so far its done great.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help, New Skis, No Fuel
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 05-28-2007, 09:46 PM
  2. 2001 polaris virage no spark & no fuel
    By paintballer89 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 05-01-2007, 07:49 PM
  3. no fuel
    By waterhogg in forum Polaris Open Discussion
    Replies: 12
    Last Post: 04-19-2007, 04:45 PM
  4. no fuel to carbs or fuel water sepperator
    By ugadawg131 in forum Polaris Open Discussion
    Replies: 33
    Last Post: 03-01-2007, 05:34 PM
  5. No Fuel to the carbs! Newb needs help!
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 19
    Last Post: 01-30-2007, 01:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •