Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    fuel delivery...

    Hey guys, first post- Ill update my profile soon... Ive got a customers 97 sltx that I cannot figure out. It runs out of fuel after about 45 secs of wot. He brought it in for carbs (wouldnt run at all), I put new kits in and jetted acordingly. Lake test went great, until it ran out of fuel. Ive changed all the "grey hose" to tygon, fuel selector is good- no restriction... Have you guys seen bad pick ups? Thanks in advance! John


  2. #2
    welcome to the hulk.
    first off you said that you put new hoses in... check to see if you mixed any of them up.

    Did the ski start up after you put more gas in or would it not run at all?

    Check all fuel lines for kinks or leaks. Also check inline fuel filters and i would replace them.

    Check your fuel pump, and fuel/water separater for water.

    Did you tow it back to shore? if so did you clamp off the water inlet hose?

    If the ski didnt start up right after you put more gas in then check the spark plugs and battery.
    battery voltage should be above 10.5 volts minimum when pushing the start button.

    Also read around for similar posts t see if you can find the problem.

    Keep us posted and good luck with this ski.

  3. #3

    Unhappy

    Thanks bossd, I have checked it all out. The problem is dead on reliable.... Crank until it starts, let it warm up for a minute or two and its fine. Part throttle is great and responsive. Full throttle or a heavy load and it will run great until it runs out of gas. In fact, when it falls on its face I can let off and it will keep idling. If I idle for a couple more minutes, it will accel again and then the problem repeats. Its starving for fuel. I guess the next step is pulling the pick up out and checking it- Does it use a sock?? I havent worked on too many pols, just yamaha and I havent had this problem before.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    How full is the fuel tank?
    Full to the top?

    Be sure you haven't gotten the fuel pickup and return lines crossed somewhere.

    Fuel filter replaced, AND no air leaks anywhere from the tank to the fuel pump?

    Do you have a fuel/water separator?
    No air leaks, no water?

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Check the fuel tank venting system..

  6. #6
    Tank is about half full. No air leaking in- no bubbles... Has a wsff but it has no water in it and flows good. Ive checked the vent, and it works, but has some restriction. Ill try taking the vent hose off and see how that helps. The problem is that we are swamped! Ive got little time to lake test and Id like a couple more suggestions b4 I hit the water. Thanks guys, keep em comin!

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    1. Tank Vent
    2. weak pulse to pump
    3. weak fuel pump
    You said you did the carbs any junk in the screens?
    the fuel pick-ups do not have any screens they are open.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by shrinerlakemarine.com View Post
    ...checked the vent, and it works, but has some restriction. Ill try taking the vent hose off and see how that helps...
    There are two vents, one allows air into the tank, the other allows air out.

    Could you have installed one of the vent valves backwards?

    The air OUT valve vents to the outside of the hull. The air IN valve just hangs inside the hull on the hose tee.

    If you can test ride with the gas cap cracked open (and not get water in the tank), and the problem goes away, then it is a venting issue.

  9. #9
    when you say "sock" do you mean around the fuel pick up?

  10. #10
    Yeah, a sock around the p/u. (thought some older pols had them?) The pulse lines are new as are the fuel pump kits. No sediment on the carb fuel filters, no water in the tank. This thing scoots good until it runs out of fuel... Ill try crackin the cap, too.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about 96 sl780 fuel delivery system...
    By jcc011185 in forum Polaris PWC Performance
    Replies: 12
    Last Post: 11-03-2011, 08:07 AM
  2. 95 sl750 fuel delivery problem
    By IndyAl in forum Polaris Open Discussion
    Replies: 40
    Last Post: 10-10-2009, 11:33 AM
  3. Anyone have an 08 RXPX with fuel delivery n starting issues??
    By ModularJunk in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-25-2009, 08:28 PM
  4. 96 GTX fuel delivery
    By GRM in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-12-2008, 06:16 AM
  5. Generic Fuel Delivery issue--What am I missing????
    By seaobin in forum Polaris Open Discussion
    Replies: 22
    Last Post: 12-06-2007, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •