Results 1 to 9 of 9

Thread: mph question?

  1. #1

    mph question?

    i got a question for everyone i have an 05 rxp and it was doin 68 mph out of the box i blew the sc clutch at 5.5 hours and had it replaced. i now have about 5 hours on the new clutch and it will only do about 63 any ideas of what i should look for?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    Is it much hotter now?

    Wear ring?
    Impeller?

    Could be a number of things.

  3. #3
    my impeller looks good no dings or dents. the temp hasnt changed much mabye 5 degrees. What and where is the wear ring?

  4. #4
    scooby-rxp-doo's Avatar
    Join Date
    Jun 2005
    Location
    South Coast, UK
    Posts
    82
    Look up inside the intake grate with a flashlight.

    The white plastic you can see that the impeller spins in (and seals to) is the wear ring..look for scrapes etc that will break the suction.

    Here's Jerry's (his is S/Steel, yours will be white)



  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    dang i forgot how TIGHT that clearance realy is supposed to be. with my plastic ring i can see broad daylight between the impeller blades and the wear ring... good 1/16" gap or so i'd say.

    that pictures makes me want to buy a SS wear ring... but i still won't drop the 300 for it. i think that's an absurd amount of money, there's gotta be a cheaper way or something.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    You can do it the Skat Trak way where they machine down the plastic wear ring and put a thin piece of stainless over it. $215 when you go that route.

  7. #7
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,929
    +1
    1
    mrwookiestinks - you had only 5.5 hours on your ski when the clutch went out? How were you breaking it in? That's a bummer and it's never gotten above 63 or close to 68 ever since the repair? Same riding conditions as when you hit 68 previously (temp, humidity, chop...)?

  8. #8

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by Shibby1485
    dang i forgot how TIGHT that clearance realy is supposed to be. with my plastic ring i can see broad daylight between the impeller blades and the wear ring... good 1/16" gap or so i'd say.

    that pictures makes me want to buy a SS wear ring... but i still won't drop the 300 for it. i think that's an absurd amount of money, there's gotta be a cheaper way or something.
    you could take your old wear ring out and turn it round for a temp measure, because the prop only uses half the area of the ring, ive done this loads of times cos i ride in a tidel siltie river and it caines wearings, when you buy a new ring take it two a small engineering shop and ask them to copy it, does'nt have to be stainless, mild steel will do the job, and is very cheap, regards bill

  9. #9
    i was babying it i never jamed on the throttle. i did a couple of rull throttle pulls but slowly. it was boosting then i decided to stop at a beach in the river i then hoped back on and took off and no boost would build the dealership said it had a defective clucth and they changed out the entire s/c

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question on aftermarket impeller for more mph
    By markdgenesis in forum Polaris PWC Performance
    Replies: 20
    Last Post: 11-21-2009, 07:41 AM
  2. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  3. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  4. Franks 80+ mph videos and results from Saturday
    By Enufpwr in forum 4-Tec Performance
    Replies: 16
    Last Post: 09-11-2008, 01:54 PM
  5. weight / mph question
    By Superunatural in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-01-2008, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •