Results 1 to 7 of 7
  1. #1

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716

    Questoin about pump

    Hey guys,

    Now that I have my engine out I was turning the back side of the coupler and was wondering how stiff should it be? It's not stiff, I would say it's secure all baerings feel good. Should it spin free at all if I put a turn on it or will it just stop?

    I'm not very worried about it unless I hear different from you all.


  2. #2
    It will turn smoothly but will not spin freely

  3. #3

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    ??? I will go back and check... I'm just not sure it feels like I would expect. I will let you know.

  4. #4

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    I have an 05 too and when I went to install a new prop I saw that it turned tight. I removed the cone also to change the grease and saw that the nut was loose, retighten it and it would not turn. The bearings had moved off the seat. I installed them and retightened the nut and the prop turned free. The ski had less then 30 hours on it.
    Mike

  5. #5

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    Quote Originally Posted by mikel70
    I have an 05 too and when I went to install a new prop I saw that it turned tight. I removed the cone also to change the grease and saw that the nut was loose, retighten it and it would not turn. The bearings had moved off the seat. I installed them and retightened the nut and the prop turned free. The ski had less then 30 hours on it.
    Mike
    Mike,

    Let me know if I can talk with you this weekend. I would like to get some input from you about what you worked on. PM me your number if you can and I will call you on Saturday.

    Scott

  6. #6

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716
    I wander if that's where some of my speed has gone??? I hope there's not to much damage if this is the case!!!

  7. #7

    Join Date
    Nov 2005
    Location
    Charleston, SC
    Posts
    374
    there was no damage to mine, it was just stealing Hp. The speed is the same but it seems to be getting there faster. I'll PM you my number.
    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hey 300X owners lets talk about pumps, venturies and cones
    By Green Hulk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 121
    Last Post: 10-30-2015, 03:41 AM
  2. Replies: 6
    Last Post: 07-05-2012, 07:15 PM
  3. Noob question about pump angle/propulsion
    By XDAILY in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-23-2011, 04:41 PM
  4. question about pump
    By stevorxp007 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-18-2010, 03:45 AM
  5. need info about pump bearings
    By homebrew in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-13-2010, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •