Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142

    new shop stand smw style

    here she is. Dont mind the 2 stroke castor smelling race fuel smoke.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_1425_158.jpg 
Views:	128 
Size:	753.9 KB 
ID:	5391   Click image for larger version. 

Name:	100_1424_168.jpg 
Views:	89 
Size:	734.3 KB 
ID:	5392   Click image for larger version. 

Name:	100_1423_392.jpg 
Views:	100 
Size:	737.6 KB 
ID:	5393   Click image for larger version. 

Name:	100_1422_103.jpg 
Views:	94 
Size:	773.5 KB 
ID:	5394  


  2. #2
    ramnj's Avatar
    Join Date
    Apr 2005
    Location
    New Jersey
    Posts
    1,713
    Look like it came out real nice.

  3. #3
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    That's bad-ass!!

  4. #4
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    thanks guys!

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Let me guess... You cranked the XLT again.

  6. #6
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    nope that be gpr smoke.

    Not idling so well. #2 head is leaking from the upper oring on the top of the head so I need to change that out. Probably need new plugs . Wierd thing is it acts like something is dragging the rpms down almost as if it wants to stall. I need to fix the head get new plugs and crank it off again. If it still does it I might have a intermediate shaft alignment problem. If thats the case I probably wont have a chance to fix it before the ming race.

  7. #7
    MR. SCOVILLE UNIT SUCKMYWAKE's Avatar
    Join Date
    Aug 2005
    Location
    ASTON, PENNSYLVANIA
    Posts
    2,836
    +1
    8
    HELL YEAH. DID YOU FILL IT WITH EXPANDING FOAM FOR ADDED STRENGTH? I DRILLED A FEW HOLES HERE AND THERE AND SHOT IT FULL. LOOKS AWESOME JOE.

  8. #8
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    Good tip on the foam ill do that for sure. It was kindof funny how i printed out a picture of your stand and was scaling it off trying to match your measurements. I think my stand is about 6 " longer than yours just like my penis is 6" longer than yours. Just ask your wife!

  9. #9
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23

  10. #10
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Quote Originally Posted by Insanediego-gpr
    nope that be gpr smoke.

    Not idling so well. #2 head is leaking from the upper oring on the top of the head so I need to change that out. Probably need new plugs . Wierd thing is it acts like something is dragging the rpms down almost as if it wants to stall. I need to fix the head get new plugs and crank it off again. If it still does it I might have a intermediate shaft alignment problem. If thats the case I probably wont have a chance to fix it before the ming race.
    Did you put the missing spring on the Novi's? That will help dramatically. If you had one more, I'd even suggest that. Also, if you upp'd the compression, and you got bad head orings, you are back in the ADA-HEAD hell again.

    What's up with the intermeddiate shaft? Is it binding somewhere? Did the driveshaft slide in easy? What were the measurements on the couplers?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Brand new aqua cart shop stand
    By H2HO in forum General Classifieds
    Replies: 7
    Last Post: 10-14-2009, 06:38 AM
  2. New 08 Stand UP??
    By ph2ocraft in forum HSR-Benelli - Hydrospace PWC
    Replies: 35
    Last Post: 03-10-2009, 05:40 PM
  3. Replies: 18
    Last Post: 07-08-2008, 04:49 PM
  4. My new shop cart
    By ZMANN in forum Shops, Tools and Tricks
    Replies: 7
    Last Post: 11-13-2007, 07:10 AM
  5. JD 1's new shop
    By gtxsc03 in forum 4-Tec Performance
    Replies: 48
    Last Post: 04-11-2007, 06:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •