Results 1 to 8 of 8

Thread: SL750 RPM's

  1. #1
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1

    SL750 RPM's

    Hey all,

    We were out riding and the 750 is running well, less the problems I am causing.

    However, I am only turning max 6050 RPM's My pistons look good, good wash, and I am afraid to lean it out at all to gain RPM's. I have 135# on all cylinders.

    What else could cause RPM loss? (might be too open ended)

    Thanks


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Have ya tried running w/ the seat off?
    How much wash do you have?

  3. #3
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Quote Originally Posted by starflight View Post
    Have ya tried running w/ the seat off? Whatcha thinking AIRFLOW??
    How much wash do you have?
    About a finger nail at each port

  4. #4
    BBCaprice's Avatar
    Join Date
    Apr 2007
    Location
    Titusville FL
    Posts
    750
    Ride it with the seat and f/a off and watch it pick up some r's...........

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by seaobin View Post
    About a finger nail at each port-whatcha thinking-Airflow?
    Possible exhaust leak. Burn't gases don't burn well.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Was a different impeller installed?

    Are the stator bearings turning freely?

    Did the RPM go up when coming out of the water?

  7. #7
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    stock impellor
    bearing sound and feel fine (smooth)

    Will have to check on teh out of water revs

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Check the intake area is clear of obstructions as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95" sl750 rpm issue
    By Kaleb SL750 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-09-2012, 01:20 PM
  2. 95 sl750 rpm
    By pitbullsoul in forum Polaris PWC Performance
    Replies: 7
    Last Post: 04-05-2010, 05:03 PM
  3. Polaris 1994 sl750 rpm limiter
    By jbwoodshop19509 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-03-2009, 08:01 PM
  4. '95 sl750 rpm issues
    By scrappy in forum Polaris PWC Performance
    Replies: 5
    Last Post: 09-24-2008, 03:53 PM
  5. RPM's of a 93 SL750
    By ph2ocraft in forum Polaris PWC Performance
    Replies: 11
    Last Post: 09-12-2006, 12:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •