Results 1 to 9 of 9

Thread: EFI Settings

  1. #1

    Join Date
    Jan 2006
    Location
    Tampa Bay area
    Posts
    41
    +1
    1

    EFI Settings

    Took my Riva Stage 2 (04 GPR) out today for the first time, would only turn 6950 rpms. I am in Palm Harbor, Florida just down the road from Jim, temp this am was around 67. I have the full Riva 2 kit plus the race air filter, V force 3 reeds and the jet works flow kit. Efi is set at 2/4/8/3. Boat pulls hard and has a strong mid range, seems like I am missing about 150 rpms. If the efi is off, would that make that much difference? Just trying to get a solid base before I take it to Jim, thanks.


  2. #2
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    First of all Read This entire thread > lots of info about this. http://www.greenhulk.net/yamaha/viewtopic.php?t=1148

    Then try 6-6-1-9 on your efi controller (Just try it and see what heppens).

    Each setting for a controller is going to be different depending on the mods that you have, so these settings will be a good starting point for you (since you do not have porting).

    Give it a try and let us know what happens.

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    hello gprran1, We are going out tomarrow with fernando to test leo's ski. give me a call and meet us out there and i will set the efi up. It sounds like he set it way of. You should be over 7200 rpm.s

  4. #4
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    yea- those settings sound off in a bad way.

  5. #5

    Join Date
    Jan 2006
    Location
    Tampa Bay area
    Posts
    41
    +1
    1
    Thanks Jim, I will call you in the am. Not sure why Brett set it this way, when he did my 00 with the factory pipes, he was dead on, thanks again, Bill.

  6. #6

    Join Date
    Nov 2005
    Location
    All over
    Posts
    716

    Re: EFI Settings

    Quote Originally Posted by Gprran-1
    Took my Riva Stage 2 (04 GPR) out today for the first time, would only turn 6950 rpms. I am in Palm Harbor, Florida just down the road from Jim, temp this am was around 67. I have the full Riva 2 kit plus the race air filter, V force 3 reeds and the jet works flow kit. Efi is set at 2/4/8/3. Boat pulls hard and has a strong mid range, seems like I am missing about 150 rpms. If the efi is off, would that make that much difference? Just trying to get a solid base before I take it to Jim, thanks.
    YEP, that red (high end) dial "8" is WAY off!!! That will KILL your top end. Depending on how she feels I would bring the mid down just a bit to about 3ish, and set your red (high end) to about 2. You WILL see gains! I have an '05 and it was big when I had mine all screwed up!

    Scott

  7. #7

    Join Date
    Jan 2006
    Location
    Tampa Bay area
    Posts
    41
    +1
    1
    Scott, seems everbody is on the same page. Hope to get out today with Jim if the weather clears, thanks for the imput.

  8. #8

    Join Date
    Jan 2006
    Location
    Tampa Bay area
    Posts
    41
    +1
    1
    Well, meet up with Jim at the causeway, changed the high speed to 2, I was wrong, it was at 1 not 8, my bad. Went to the lake on the way home, picked up 50 rpms, condtions were very close to Saturday. Lucky for me Fernando was there as well, put my sponsons all the way down, boat rides better. Will take it to the shop and let them try to get it dailed in, if not will take it to Jim. Not sure what the problem is, did do a compression check, all at 150 lbs. Thanks Jim and Fernando for the help/input today!

  9. #9

    Join Date
    Jan 2006
    Location
    Tampa Bay area
    Posts
    41
    +1
    1
    Went to the lake today, with the efi set at 6/9/3/6 still at 7000 rpms. Going to take the ff out and go back to the stock set up. Per Jim and Phil should gain back about 100-150 rpms. The bottom end is better and the mid range is still good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. efi settings after vf3 reeds and race filter?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-12-2006, 10:49 PM
  2. What EFI setting to start with?
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 05-08-2006, 08:01 AM
  3. EFI Settings
    By Gipper in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-21-2006, 10:18 AM
  4. whats a good efi set up for my ski ?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-14-2006, 09:05 PM
  5. efi settings
    By superramjet in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 12-13-2005, 04:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •