So im trying to install a game and it says I need DX9c or higher to run it...but, I have it installed. I tried to reinstall and it says I have it already and wont install. anyone have ideas?