Results 1 to 10 of 10
  1. #1
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3

    RXP-X electrical problem

    So, my ski has been parked for about 2 months, went to start it last night and nothing happened but the main relay was buzzing. Figured the battery was dead so replaced it and same problem. I had another relay from another ski and it continued to buzz. I noticed that when I pressed the VTS switches the buzzing would stop then start again, so I pulled the switch and one side was hot and shorting out. Why would the VTS switch short out? Should not the fuse blow is there is a short?


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    the only similar thing i have seen is when 1 of the plugs going up tp the handle bars was missing the orange seal and salt water got in and was making a weak contact which made the buzzer make a faint whirring noise so cleaned the plugs with contact cleaner and replaced the seal.
    does your ski run now with the vts unplugged? if it keeps doing it unplug the trim unit at the rear of the ski.

  3. #3
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    It was a defective steering harness, I borrowed a harness from another ski and its working fine again. Salt is a killer.

  4. #4
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,581
    +1
    4,795
    I think your X is punishing you for having that green thing in your avatar.
    salt is a bee-atch for sure, glad you got it fixed bro...

  5. #5
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Quote Originally Posted by YoYamma View Post
    I think your X is punishing you for having that green thing in your avatar.
    salt is a bee-atch for sure, glad you got it fixed bro...
    You cant be in front all the time, I mean that just would not be fun for the others

    Cant wait to get the X out as I just modified the crap out of it, just waiting for the pump extension so I dont get pitched

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,581
    +1
    4,795
    I would still love to get down there and ride with you guys...
    maybe some day.

  7. #7
    Ramming speed Mr Zulu! TeamYamSHO's Avatar
    Join Date
    Aug 2008
    Location
    Antigua, W.I
    Posts
    133
    Quote Originally Posted by YoYamma View Post
    I would still love to get down there and ride with you guys...
    maybe some day.
    Yoyamma! You should man! Its a blast!

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Antiguan RXP View Post
    just waiting for the pump extension so I dont get pitched
    Thats not going to keep you from swimming

  9. #9

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    Dont count on the pump extension to cure the bucking/overstuff

  10. #10
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Some of the pro guys have told me that extension is the answer.

    Time will tell...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 sea doo rxp 4 tec electrical problem
    By KEN TODD in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-22-2014, 05:20 PM
  2. 05 RXP electrical problem
    By Roger H in forum 4-Tec Performance
    Replies: 1
    Last Post: 01-27-2008, 09:23 PM
  3. '04 GTX SC electrical problem
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2006, 06:49 PM
  4. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM
  5. RXP Rotax RPM problem... we're helpless
    By Shibby1485 in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-28-2005, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •