Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250

    Battery problems

    I went to 3 diferent battery's in a week,we check all fuses are ok no corrosion.Any one knows how to check the voltage regulator?


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    if its not charging the regulator is the most likely cause and the only way to test it is by eliminating everything else by ohm checking the stator and wiring etc so usually need to just plug in a known good unit and see if it charges (it will most likely be faulty). Just make sure there is no corrosion on the plugs and check the plug at the engine next to the ecu with the 3 yellow wires.

  3. #3
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    Just check those 3 wiresand they are clean.Any other sugestion?

  4. #4
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    ttt

  5. #5
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    try another regulator! mounted above the fuel tank

  6. #6
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    Regulator its by the battery?rigth?

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Check the voltage of the battery with a full charge and the engine not running. It should be close to 12.5 VDC. Then start the engine and check the voltage. It should be 13.5 VDC or above. Let us know what the two readings are... Ron

  8. #8
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    I will do that in the morning,thanks

  9. #9
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    it will by the battery if the riva stg 3 bracket is used its got fins on it and 2 plugs 1 with a black and red wire and 1 with yellow wires.

  10. #10
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    Ok,but still wana check in the morning

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. frustrated again....battery problem
    By paramuir in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-27-2008, 08:46 PM
  2. '06 Sea Doo GTX 4 Tec Battery problems!
    By ohanaporvida in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2007, 06:31 AM
  3. Battery Problems-Does this sound familiar?
    By SeaDoocer in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2007, 10:24 AM
  4. Battery problems?
    By SHIFT in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-15-2006, 08:09 PM
  5. battery problems
    By peter in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-04-2005, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •