Results 1 to 7 of 7
  1. #1

    COUPLE MORE PICS OF MY "NO BRAKE SYSTEM"

    Took a couple more pics, different angels, will be here shortly, soon as the misses gets done she'll transfere to my E-mail and then I'll post.


  2. #2
    Here ya go. That pic came out small took same pics with same camera
    Took pics with the same camera as yesterday everything came out different.
    Attached Images Attached Images    

  3. #3
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    You dont need brakes to go fast.
    Lets have some before and after #s now the brakes are gone.
    SCOTT........

  4. #4
    Well The ski is stock, 67mph, with my "HANDLING PACKAGE" and my 05 pump parts I think I'll do just fine Plus my real speeds will come from my ...........uuuhhh...3*% uuhhhh hp kit

  5. #5
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    I never thought I would see a camera that was worse than mine! Thanks Pete...there is hope for us bad camera users yet.

  6. #6
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,799
    +1
    449
    I am glad someone had the cajones to cut up the back of their boat. I considered it a few months ago, but would be PISSED if it didnt work!!!

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    I am glad someone had the cajones to cut up the back of their boat

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Couple of Pics of my EMS all hooked up....
    By lawracing in forum 4-Tec Performance
    Replies: 67
    Last Post: 04-13-2006, 12:17 AM
  2. Pics of my fan powered air intake
    By nitro rxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-12-2005, 03:40 AM
  3. NEW CAMERA!! So here are some pics of my Race Tech kit
    By two2curupt in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-27-2005, 07:45 AM
  4. Pics of my 2005 RXP on FIRE!
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-31-2005, 03:18 PM
  5. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •