Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2004 MSX 150 will not stop running

    2004 MSX 150 will not stop running

    Moved this from the general discussion area.

    2004 MSX 150 will not stop running, I have to disconnect the battery to get it to stop. I have confirmed the stop/lanyard switch is working properly and I see the SWITCHED ECU VOLTAGE go from 12volts to almost zero when the lanyard is removed. I have traced the purple wire back to the System IFB pin H. However I see NO Transition on pin C BLU/WHT SWITCHED ECU VOLTAGE when the stop switch is pressed. It remains at around 10 volts which is strange. I would expect it to change from around 12 volts to zero as the lanyard is removed or the stop button is pressed.
    I suspect a bad System IFB but there does not seem to be any reported problems like this on the MSX150 Start / Stop Electrical System.
    Opinions please !



  2. #2
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    yeah it sounds like you have a bad main IFB(system IFB). Unplug it and tap it on the flat surface of the IFB and see it it works any better. In either event that is what is wrong. It is not powering down the machine. It is common for those to go bad. Instead of disconnecting your battery just disconnect you main relay(brown box next to ecu) and it will power down the machine(shut off) and I would unplug the IFB and leave it out until you get a new one. I have seen then MELT!!!!

    Hope this helps
    Jay

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Thanks Jay, it's always so nice to have you here to help us out with these 110/150's and the ...

  4. #4
    Thanks for the confirmation. I'll get the part on order. I'll try slapping it around a bit as a temporary workaround.

  5. #5
    Replaced IFB and shut down switch works


    Update. Ordered and recieved a new system Interface Block and the lanyard Kill and stop switch now work porperly.

    Thanks for the kind assistance.

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Thanks for the update, good to hear!!

  7. #7
    Ctek's Avatar
    Join Date
    Dec 2008
    Location
    Chi-town
    Posts
    135

    Tangent problem

    First off thanks for the question and the fix. What a great forum.

    I am looking at a similar problem though insted of not shutting off the craft will go to immediate high revs upon start up. It will shut off with the kill switch.

    Any ideas? Bad TPS?

    Thanks

  8. #8
    I know this is an old thread, but I just ran across this problem with my MSX 150. Would someone be so kind to tell me where the System interface block is located? Also is there anything else I should check to see why the 150 will not shut down when the lanyard is pulled or the button is pushed. Thanks

  9. #9
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    The System InterFace Box (SIFB) is located back by the battery. It's plugged into the wire harness, usually just hanging there, above the battery, below the ECU and near the main relay... rear right side. (Just FYI... there is another IFB box plugged in up in the nose, below and near the steering column in the right side wire harness. This IFB is for the PPU (Pedal Position Unit... part of the eThrottle))

    Here is the service manual page for the SIFB:



    Hope that helps. Cheers!

  10. #10
    ok, So my next question is, where do I buy one of these? I tried a few places and they all said they are out of stock and discontinued.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 06-24-2015, 10:58 PM
  2. MSX 150 Will not run over 40
    By trn1977 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-22-2013, 12:10 PM
  3. MSX 150 Will not run over 40
    By trn1977 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-17-2013, 11:01 AM
  4. Msx 110 will not stop running
    By keskinner23 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 08-26-2012, 09:56 PM
  5. 2004 MSX 150 will not stop running
    By tsummerl in forum Polaris Open Discussion
    Replies: 4
    Last Post: 11-13-2008, 05:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •