Results 1 to 2 of 2
  1. #1

    Power Valves on xl1200 1999

    Sorry for all the questions guys.

    I don't think the power valves are opening...when i start the ski and turn it off they should cycle right ? They do not.

    So i have loosened the cables to eliminate sticky power valves put they still don't work. I have power going through the red wire with a blue trace which goes to the power valve motor so i guess that's as it should be.

    Can i power up the power valve motor (What turns the cables to the power valves) to see if that works. I have no problem replacing a faulty part but just want to make sure that's what the problem is


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Download a service manual from the how to section. It has detailed tests for the PV motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power loss on my 1999 yamaha 1200 XL Please help..
    By nicolasbermudez in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-31-2012, 02:31 PM
  2. Missing power valve on a xl1200
    By coolsea860 in forum Open Discussion
    Replies: 2
    Last Post: 06-09-2011, 06:49 PM
  3. Replies: 1
    Last Post: 03-30-2010, 01:51 PM
  4. 1999 1200xl power valve issue
    By LKN FUN in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-21-2008, 07:31 PM
  5. 1999 1200xl Power Valves /cdi ??
    By LKN FUN in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 08-06-2008, 08:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •