Results 1 to 10 of 10
  1. #1

    2001 Polaris SLX 1200cc that seems to choke itself off half throttle HELP!!!!

    I just bought a 2001 Polaris SLX 1200cc that seems to choke itself off half throttle. The ski starts great, idles smooth, and revs good. When it is in the water I can only throttle it half way or it seems to choke itself off and wants to die and has no power. Checked the fuel filter and added new gas. What else can I do? I replaced ALL the fuel lines and cleaned the carbs and the ski does not want to get out of the water. It seems to run stronger but still chokes itself off at half throttle. Could the carbs be out of sync? Could it be the reeds? Magnito? too much oil from fogging system?


  2. #2
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405

    green gunkus

    remove the flame arrestor cover and you might have to pull the base as well to gain acces to the return line,pull the return line off the center carb.its connected to the brass fitting at the top rear of the center carb 5/16 line.reinstall the base plate,with the ski on the trailer and half in the water(be prepared to shut the ski off)start it,does fuel spray from the brass carb fitting???what about if you rev it a little???

  3. #3

    2001 Polaris SLX 1200cc that seems to choke itself off half throttle HELP!!!!

    I have replaced ALL the fuel lines, and bought rebuild kits for the carbs and rebuilt them. I have also put in new carbon fiber reeds. Is this a fuel air ratio problem between the three carbs? How can I set and adjust the carbs to run properly if this is the problem? It also seems like its burning a lot of oil. The exhaust is very white, I understand how a 2 cycle works but I would not expect for the exhaust to look like a thick white cloud of smoke. Any suggestions before I take it to a dealer and pay out the wazoo?

  4. #4
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    I would check compression, Could have water getting into a cylinder maybe.

  5. #5
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405

    oil

    sounds like the oil pump lever flipped over while the carbs were off.

  6. #6
    Does it do it on land or just on water? If just on water, check your exhaust. Im having the same problem, and it's in the shop now. The first thing they are looking at is the exhaust.

  7. #7
    Compression checks out good, is there anything I could do about the oil pump? I will check the exhaust this weekend. When the engine is idleing and I am trying to run it all three cylinders are running at different temperatures to the touch, the front cylinder runs the hottest, middle one is warm, and the third is almost cool to the touch. Anything else to check?

  8. #8
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by TxPro1200 View Post
    sounds like the oil pump lever flipped over while the carbs were off.
    This is the first thing I thought of, especially if it happened after the carb rebuild.

    Quote Originally Posted by Crash_6565 View Post
    Compression checks out good, is there anything I could do about the oil pump? I will check the exhaust this weekend. When the engine is idleing and I am trying to run it all three cylinders are running at different temperatures to the touch, the front cylinder runs the hottest, middle one is warm, and the third is almost cool to the touch. Anything else to check?
    Normal when on a hose as the pressure is lower as it moves further into the engine.

    In the tech section you'll find the manual and directions to adjust the oil lever and make sure it's flipped the correct drection.

  9. #9
    Just realized I had this thread, I will check this as well.

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I merged the threads.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just bought a 2001 Polaris SLX 1200cc. Not running well any fixes?
    By Crash_6565 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 08-07-2014, 02:57 PM
  2. Trouble with 2001 Polaris Genesis 1200cc - Help Required
    By hockeyplayapete in forum Polaris PWC Performance
    Replies: 8
    Last Post: 05-17-2010, 04:17 PM
  3. In Need of Some Help with 2001 Polaris Genesis 1200cc
    By hockeyplayapete in forum Polaris Open Discussion
    Replies: 0
    Last Post: 05-16-2010, 06:42 PM
  4. 2001 Polaris SLX Reliability/Performance?
    By da4ad in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-26-2009, 10:59 AM
  5. 2001 polaris slx 1200
    By rhsummer in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-17-2008, 05:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •