Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 66
  1. #1
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13

    what's robbing my speed?????

    Ok so I ran my ski and here's what I get with my mods.... 71.0 mph at 7240 rpms. It pulls strong all the way til 70.5 then when it hits 71 its a brick wall and starts to bounce. Now the question is.... Where is the rest of my speed? I'm missing 5 mph. Please help anyone!!!! I'm about to give up.


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    If its an untouched R&D plate,thats were your speed went.

  3. #3
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627
    Dont give up! After my mods I dropped almost 1mph than stock and have managed to claw my way from 65 back up to just under 70. That was running a Skat prop. With the DF and some other minor tweaking I should be at my goal of low 70's Remember this a rough setup running a shred plate. Good luck and HANG IN THERE you'll be glad you did , trust me bro I felt like burning my ski the first run out

  4. #4
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    Quote Originally Posted by WATER WOODY View Post
    If its an untouched R&D plate,thats were your speed went.
    it's spuds old r&d modded plate. speedplate skegless, all surfaces trued, angle set to 5 degrees. i just spoke to wfo and i might send my prop off to impros and get it pitched to 14/22 or just buy a dynafly pitched to 14/22 and keep my 14/20 for holeshot racing. that should bring me up a couple mph's and looking into a SS 800 grate for 1 mph.

  5. #5
    08GPR's Avatar
    Join Date
    Nov 2007
    Location
    Sydney, Australia
    Posts
    627
    I'll be keeping an eye on this thread, I had an Impros 22 and was only turning 6840, stock airbox though still Pretty much same mods as you bro but 3 degree

  6. #6
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Let me ask you this,whats your weather like when you ran last time? Is your prop a setback now?
    You need more pitch like WFO said for sure.

  7. #7
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Add a washer on the rear bolts of your tabs. I've seen this plate in action.

    Call Spud too. He's a really great guy to deal with and is a master with these things.

  8. #8
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    What does the plate currently measure? and what kind of trim tabs and how much do you have them shimmed? I am taking for granted that your pump shoe is set correctly and sealed.

  9. #9
    Altezza01's Avatar
    Join Date
    Jun 2007
    Location
    Destin, FL
    Posts
    1,527
    +1
    13
    Quote Originally Posted by OsideBill View Post
    What does the plate currently measure? and what kind of trim tabs and how much do you have them shimmed? I am taking for granted that your pump shoe is set correctly and sealed.
    pump shoe is sealed correctly, plate measure .7 with flat edge( i need more angle), riva cut trim tabs with no shims.

  10. #10
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Can you elaborate more on the .7

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what should my speed be?
    By xpfreak in forum 2-Stroke Performance
    Replies: 8
    Last Post: 08-12-2010, 11:09 AM
  2. long high speed run, look what happen to my exhaust hose
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-28-2007, 11:27 PM
  3. What do you guys think about my speed?
    By LiquidDI in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-17-2007, 10:50 PM
  4. Heat fade killing my speed
    By nitro rxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-21-2005, 11:37 PM
  5. Can't Find my SPEED? MY RXP wont wake up!
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-12-2005, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •