Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39

Thread: LOW RPM

  1. #1

    LOW RPM

    I went to the lake yesterday to test my mod in my 05 RXP
    but I was not what I expect


    before 61 MPH 7100 RPM
    After I put Super Charger with green wheel
    new 14/19r Shark Pro,worx Intake grate,Riva82mm Nozzle,Riva Valve train
    66 MPH 7100 RPM and after I tried a Riva ECU with not change!!

    How can I raise up my RPM???

    Any suggestions?


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    61 mph at 7100 is not good to start with. What rpms are you turning? It sounds like another SC washer problem. You should be seeing 7800-8100 rpms and 66-69 mph stock... Ron

  3. #3
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    You def have some problems if you are only turning 7100.... Was the prop untouched? What air intake do you have?

  4. #4

    well

    Stock intake
    s/c was stock before but i upgrate to the green wheel with riva washer.
    Impeller it's untouch new with ss wear ring

  5. #5
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Quote Originally Posted by douglasb76 View Post
    Stock intake
    s/c was stock before but i upgrate to the green wheel with riva washer.
    Impeller it's untouch new with ss wear ring
    First off... you gotta let that thing breath with a new air intake.... but that's not going to make up missing 1000 RPM....

    Probably have a boost leak somewhere. Check all of your hoses and couplers. Stock IC?

    Check all the seals on the intake.

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    When did the ski last run right? When did you buy it?... Ron

  7. #7

    YES

    Yes i did but the wierd thing it's was same thing before with the stock super charger not change!!! Just better pick up and 3 more mph

  8. #8

    2 week

    I just bought like that
    and first thing I checked was ceramic washer that's why I upgrate to Riva with green wheel sc I bought last week to other member

  9. #9
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Sure it's not an '04 missing the knock sensor update?

  10. #10

    I

    I don't know If the knock sensor was update but that will make rpm low??

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low RPM's
    By RedRyderRXP in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-13-2006, 07:48 PM
  2. 06 rxp low rpm
    By rxpenpastu in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-21-2006, 02:25 PM
  3. Low RPM Issue
    By xenonx in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-19-2006, 03:19 PM
  4. fixing my low rpm's
    By MDGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-17-2006, 08:26 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •