Results 1 to 2 of 2
  1. #1
    JeffSki's Avatar
    Join Date
    Nov 2006
    Location
    Florida 33410
    Posts
    218
    +1
    4

    4 Tec Oil Pump Question

    Have a very low hour 4 tec 155 engine that had fresh water intrusion. I pulled off the mag and pto housings to check the oil pumps. The pump covers have some fine grooves (see pics). At this point should I replace the covers? What else? Should I tear down and inspect the main bearings? Engine turns over fine, w/170 psi per hole.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	oct 040 (Custom).jpg 
Views:	61 
Size:	154.4 KB 
ID:	102767   Click image for larger version. 

Name:	oct 044_edited-1 (Custom).jpg 
Views:	53 
Size:	134.0 KB 
ID:	102768  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Since you already have the pumps out... I would replace them, put it back together & let it ride

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil pump question
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-20-2007, 11:36 AM
  2. gtx 96 seadoo 650cc oil pump question
    By andy95'slx780 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-19-2007, 08:59 PM
  3. Oil Pump question
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-26-2007, 06:08 PM
  4. Oil Pump Question on 99 Genesis
    By VegasRatt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-03-2007, 10:29 AM
  5. SL 780 oil pump question
    By martinv in forum Polaris PWC Performance
    Replies: 9
    Last Post: 05-06-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •