Results 1 to 3 of 3
  1. #1

    2005 900stx not turning over

    Hey Everyone,

    I have a 2005 kawasaki 900stx however i cannot get it to start / turn over..

    It has not been used for about 6 months as it is just the begining of summer here in New Zealand

    (The ski was fully operational when we put away for the winter, had the ski since new and it is bone stock).

    The only thing i have checked so far is the battery and that appears to be fully charged according to my batt charger.

    When i try to start the ski there is just silence and the display turns off, once the start button is released the display comes back on.

    I tryed starting the ski with the batt charger on however i just get a clicking noise....

    Thanks in advance for your replys


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Raleigh, North Carolina, United States
    Is the Lanyard on? ( I hate to say it but I forget in the spring too)

    Try pulling the plugs out and try. ( this will reduce the torque needed to turn the engine)

    Could be a bad battery. What is the Voltage (with a meter) at the battery while trying to crank

    Can you spin the driveshaft with your hand (with the plugs out)

    Did you check to see if there is a fuse or breaker in the electrical system in line with the starter

  3. #3

    Join Date
    Sep 2008
    Charge and LOAD test the battery. Sounds like a dead cell in battery.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 sl780 not turning over
    By showoff in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-07-2009, 08:48 PM
  2. HELP HELP will not turn over dead.
    By JOSE13RT in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 07-13-2008, 04:08 PM
  3. 2000 Polaris Genesis FFI will not turn over
    By maui in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 04-10-2008, 08:24 AM
  4. port engine not turning over
    By xXxBurnStuffxXx in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 09-16-2007, 02:40 PM
  5. Jumped wave and GP 1200 died...will not turn over.
    By iam026tb4u in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 08-27-2007, 06:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts