Results 1 to 7 of 7
  1. #1
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366

    Jet Pump: Salt water really KILLS!

    So I got my ride plate in after a while of working on other stuff, no real hurry cause the weather.
    So I Got to my jet pump and impeller I took out my impeller just to check the wear ring and was greatly disappointed, I found out that the wear ring actually had chunks missing and even worse, there was water and SAND in the bearings!
    I have no idea of how such large grains of sand got into the bearing houseing.
    I took some pictures.
    What would this whole setup cost me?
    1. Houseing
    2. Impeller
    3. wear ring
    4. bearings
    5. seals
    ?
    cause by the looks of it this one has corroded a way for that stuff to get in.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0977.JPG 
Views:	59 
Size:	756.9 KB 
ID:	103405   Click image for larger version. 

Name:	100_0981.JPG 
Views:	56 
Size:	792.7 KB 
ID:	103406   Click image for larger version. 

Name:	100_0978.JPG 
Views:	74 
Size:	845.7 KB 
ID:	103407   Click image for larger version. 

Name:	100_0979.JPG 
Views:	55 
Size:	887.9 KB 
ID:	103408   Click image for larger version. 

Name:	100_0982.JPG 
Views:	69 
Size:	811.6 KB 
ID:	103409  


  2. #2
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,322
    +1
    635
    WOW that looks really bad. maybe you shuold look at buying a used pump. MAN the salt really is a killer.

  3. #3
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    this thing looks as if it was kept in the water all the time.

    And if you know someone with a used one please let me know.

  4. #4

    Join Date
    May 2005
    Location
    Louisville KY.
    Posts
    156
    that is the 03 pump you are better off getting a metal pump. you will not have the wear ring problem from pump flex.

  5. #5
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    I already bought a new one, and to be honest, I dought the engine will last the life of the pump, its got 120hours but has never been taken care of, the only reason the people sold it cause it refused to go (limp mode) that was from the oil sensor. but on the inside it looks new, but everything that sat in the water is trash
    Ride plate
    Pump
    linkages
    pretty much everything.


    It's kinna funny cause I was like, "Man, I know i have to but i dont want to take that off." cause i knew it would be bad. good thing my impeller is not broke or chiped $250 for that.

  6. #6
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,322
    +1
    635
    I am always suprised how people will do nothing to there toys and expect them to preform. sounds like you have a new to you small project.

  7. #7
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    you definitely need to get a 2004 or newer pump from a RXP RXT or GTX SC.
    it will be aluminum pump instead of plastic.
    then you need to get a wear ring for a GTX SC pump, 185hp.
    NOT a wear ring from the bigger engined skis.
    the pump housings are all the same, BUT the impellers and wear rings are different.
    you need to reuse your impeller and get the proper(185hp version) wear ring.
    the bigger HP skis has bigger impellers and wear rings.
    used pump should be 250ish in good condition, new wear ring from GH.net shoud be 40ish.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. service schedule for jet pump bearings/water seals
    By JoeyDFZS in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-04-2013, 06:05 AM
  2. Water in the jet pump :( Questions
    By Turbofab in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-18-2013, 12:36 PM
  3. Help, water inlet hose next to jet pump
    By mterry127 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-05-2012, 09:32 PM
  4. Jet pump rattle at idle in the water
    By jackofalltrades in forum Polaris Open Discussion
    Replies: 19
    Last Post: 04-14-2012, 01:44 PM
  5. Proper salt water protection
    By CRAZEDRXP in forum Sea Doo How To & FAQs
    Replies: 23
    Last Post: 02-07-2010, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •