Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Old School Never Dies! codemanrose's Avatar
    Join Date
    Nov 2006
    Location
    Minnesota
    Posts
    819

    I hate taking off impellers

    I can never get them off! Second time I have tried and fail. I have the tool and Im spinning it the right way. How do you guys get yours off? Otherwise I have to run to the shop and put it in the vice.


  2. #2
    A big arse vise
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_4580.JPG 
Views:	83 
Size:	168.2 KB 
ID:	103452  

  3. #3
    Moderated
    Join Date
    Oct 2006
    Posts
    3,711
    i borrowed mike72e's vice design, its a good quality vice ( unlike mikes which my shaft snapped the other day lol) and its bolted to a peice of 8x2 which is around 3 feet long.

    we just drive our cars over the plank of wood to hold the vice in place and wack the shaft in the spline tool and off ya go.

    keep in mind some props are complete bastards, i have a DF stuck on a shaft atm that i simply can not get off ( yet) so be patient and use a breaker bar if needed, if thats fails theres always an oxy torch

  4. #4

    Join Date
    Jan 2008
    Location
    bryan college station, tx
    Posts
    259
    thats why i always just take things like that to a shop. The local shop charges me 15 dollars and it take them like 15mins. I ve learn that doing it yourself isn't always the best way.

  5. #5
    Mike's GPR's Avatar
    Join Date
    Mar 2008
    Location
    Carol Stream, IL
    Posts
    2,044
    +1
    20
    Also try heating the impeller with a torch prior to attempting to remove. It works. Also put some anti seize on the threads when you reassemble.

  6. #6
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    I welded an old spline to a piece of 5 ft.long, 2 inch wide thick bed frame channel,at about 1/5 the length ... You can lay it across 4 x4's and then all you need is to stand on it while wrenching .. if that fails, heat the impeller with a propane torch at the hub area... hasnt failed me yet ..

    (cool thing about this tool is you can scavenge the female spline from a bunch of old intermediate shafts and then weld all the different size's to the channel, not costing you much)

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by Mike's GPR View Post
    Also try heating the impeller with a torch prior to attempting to remove. It works. Also put some anti seize on the threads when you reassemble.
    +1

  8. #8
    Old School Never Dies! codemanrose's Avatar
    Join Date
    Nov 2006
    Location
    Minnesota
    Posts
    819
    Quote Originally Posted by RX951 View Post
    +1
    Worked awesome! Thanks!! got everything back together. Also with the stator, I got a better look at it with the impeller off, got the file out and cleaned up the nicks. looks good now. Its packed up and put a way for the winter. When spring comes I start on the motor. Thanks again!

  9. #9
    Old School Never Dies! codemanrose's Avatar
    Join Date
    Nov 2006
    Location
    Minnesota
    Posts
    819
    Ok, another question. (since this does have to do with my 13/19 solas) This is what im supposed to run with pretty much stock motor but Im building on mine now and when do you have to be lookin at a different prop?

  10. #10
    Old Ski Insanity w/rpm500's Avatar
    Join Date
    Aug 2005
    Location
    Crystal River Fl
    Posts
    2,208
    IMT,most run the XO impeller with a modifyed motor ...
    http://www.solas.com/newweb/pwcprodu...o=F24&SwType=1

    top of their listing semi explains their recomendations... (signs are wrong ,but you should be able to figure it out...)

    I'm thinking now,Carl set mine at 14.5 x19.5,but i have the gp760 and had him custom bend this for my setup...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS New RXPX-260 take off, x charger, impeller, riva valve tool
    By seadoo02xp in forum Sea Doo Classifieds
    Replies: 9
    Last Post: 02-22-2012, 09:16 AM
  2. Taking Off Raider Impeller
    By Adam E. in forum Yamaha Old School Skis
    Replies: 15
    Last Post: 11-11-2009, 03:26 PM
  3. seadoo rxp sluggish when taking off, sc? or impeller ?
    By linuxglobal in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-19-2009, 03:47 PM
  4. Why take off the impeller nose cone?
    By RXP_Noah in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-04-2008, 08:05 PM
  5. Taking off the impeller cone
    By Hecyan in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-20-2006, 11:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •