Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28

    found this in my hull....???

    any ideas?? rubber, 1/4 inch wide....fyi:riva installed stage 1 and depthsounder....thanks man


  2. #2
    SeaGoat's Avatar
    Join Date
    Jun 2008
    Location
    Jacksonville, N.C.
    Posts
    2,214
    +1
    2
    I really don't know but it resembles the seal on some electrical connectors. How big is it?

  3. #3
    beachbum0286's Avatar
    Join Date
    Sep 2007
    Location
    Brigantine NJ
    Posts
    944
    +1
    1
    My guess is that is the rubber gromet that goes on the plug that plugs into the spark plug coil. It makes it water proof, check all 3 plugs one may be missing.

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by beachbum0286 View Post
    My guess is that is the rubber gromet that goes on the plug that plugs into the spark plug coil. It makes it water proof, check all 3 plugs one may be missing.
    It looks like the rubber cover that goes on the sensor plugs.
    You have a plug like that on exhaust sensor, thermo or oil sensor(not sure but its right above sc), and one of intake manifold sensor.

  5. #5

    Join Date
    Aug 2006
    Location
    Gonzales, La
    Posts
    2,145
    +1
    9
    Hmm, I lost that very part in my hull and haven't found it yet. Maybe there is a wormhole that connects our hulls and that one is really mine. I'll PM you my address so you can mail it back to me.

  6. #6
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Fl
    Posts
    1,735
    +1
    28
    Quote Originally Posted by skoepp View Post
    +1
    thats what it looks like to me,
    You have a plug like that on exhaust sensor, thermo or oil sensor(not sure but its right above sc), and one of intake manifold sensor.
    That makes sense....found it right below the waterbox....

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by Kaybat View Post
    That makes sense....found it right below the waterbox....
    You know the line that connects to water box (sensor). It should have one of those orange deals like in your picture.
    I also have had one floating arround in hull and did not know what it was.

  8. #8
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    could be wrong but it looks like the seal to one of the coil conections. probebly poped out when you got it serviced while changing plugs. lift your top plastic engine cover off and unplug the three coils and most likly will have one missing. they don`t sit in to well after a while.

  9. #9
    coil pack seal seen it many times on the boats I work on.

  10. #10
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    The coil connectors and other harness connectors share the same seal.
    Mine fell off a few times into the bilge.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Found this bolt in my hull.
    By Rxp_speedracer in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-13-2016, 12:11 PM
  2. Found this in my hull, What is it?
    By infamous in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-10-2013, 11:22 AM
  3. HELP! found this in my hull. 98 gsxl 951
    By 98gsxl951 in forum 2-Stroke Performance
    Replies: 10
    Last Post: 05-25-2010, 09:52 AM
  4. this will affect my perfomance a hole in my hull what to fix it with???
    By spyder3000gtvr4 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 09-21-2007, 10:26 PM
  5. Trim tabs bolt loose....will this leak in my hull???
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-03-2006, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •