Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238

    Question Exhaust Manifold to J-Pipe Ring damaged

    I recently upgraded with several parts. I had to make a repair today to the connection into the Ride Plate (was leaking antifreeze). During the repair I had to pull the J-Pipe.

    I noticed the ring at the end of the exhaust manifold where it connects to the J pipe had seems to have disintegrated some. In other words, the ring has a spot where the ring is no longer 100% there. It seem to be missing. I also noticed some "grainy" or "salty" looking pieces where the J-Pipe and manifold meet.

    I rode about 1.5 weeks ago and never had any high temp alarms or any issues. Any thoughts?

    Thanks!


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Sounds like you are running a little lean and melting the manifold bell.

  3. #3
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238
    Thanks for the response. I don't have an AF monitor installed yet. I do have some 42 lb injectors that I have not yet installed. Should I install the 42s yet? (I was planning on waiting until the Fizzle intercooler install.)

    thanks.

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    I would. You are very borderline with the g-wheel and shorty freeflow exhaust with the cooler temps you are probably seeing.

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Bats,

    Exactly what mods are in your boat??If all the mods you listed in your sig. is in your boat right now then NO you dont need to put the 42s in..The 38s are fine..My wifes boat is running almost the same identical mods except for the prop and her ski is running with no issues...

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Snoman View Post
    Bats,

    Exactly what mods are in your boat??If all the mods you listed in your sig. is in your boat right now then NO you dont need to put the 42s in..The 38s are fine..My wifes boat is running almost the same identical mods except for the prop and her ski is running with no issues...
    I would agree with this if he wasn't melting the exhaust bell.

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by speedskixp View Post
    I would agree with this if he wasn't melting the exhaust bell.
    This is a wierd subject cause i melted my exhaust bell on two differant manifolds and thought i was running lean...I put an A/F guage on her and she was perfect as far as the A/F goes...Me personally i dont think its all caused by a lean condition...IMO some of these bells that are melting are melting due to the higher EGTs generated by higher boost..It seems once you put in a bigger wheel they start to melt..And its also funny cause i have seen some skis here that were running terrible lean and no melted bells..I wish i could figure that one out But IMO a melted bell doesnt always mean your running lean..

  8. #8
    sweetbats's Avatar
    Join Date
    Mar 2008
    Location
    Glen Allen, VA
    Posts
    238
    Thanks for the thoughts. All the mods in signature is exactly what I ran last time. The air and water are starting to get cooler. I have an AF bung but no meter as of yet. Need to sell some bats to pay for one!

    What is the worst case if the bell melts all the way? (I don't want to do any damage.)

    I can swap to the 42s, no problem, but don't want to make a mistake and run too rich.

    I know getting the AFR gauge is essential, I just cannot do it now....

    Thanks!

  9. #9
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    I would rather be a little rich than lean and adding fuel will cool your EGT.

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    With the stock IC the 42s might be a tad to much till you get Fizzles IC installed..As far as the bell being burnrd i have had no issues running mine..Just make sure your J-pipe and exhaust manifold flange is sealing so your not leaking exhaust gases back into the engine compartment..

    Quote Originally Posted by speedskixp View Post
    I would rather be a little rich than lean and adding fuel will cool your EGT.

    +1...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Brand new Exhaust clamp for Exhaust manifold to J-pipe
    By BH03 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-12-2016, 06:06 PM
  2. 785 exhaust manifold to pipe O Ring
    By ktheake in forum Polaris Tech Tips and Info
    Replies: 5
    Last Post: 06-02-2016, 09:15 AM
  3. Need 08+ exhaust manifold to mid-pipe V-band clamp
    By sea-one in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 04-14-2014, 10:47 PM
  4. WTB exhaust manifold to water box braket 08 rxp-x
    By AdrianRXT in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 02-09-2010, 01:33 PM
  5. GPR manifold to U pipe piece for sale
    By Vern in forum Yamaha Classifieds
    Replies: 2
    Last Post: 05-22-2009, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •