Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174

    starting without pump

    Just a simple question!Can I start my ski to run anti-freeze thru it without the driveshaft and pump installed?If noone is sure i'll just put it back together,I'm just waiting for another pump!Thanks Scott


  2. #2
    Absolutely no prob starting the motor without the pump ! nothing in the pump is locating or holding or dependent on the engine pto thru hull etc

  3. #3

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    your ok to flush,just don't buzz the hell out of it

    later cd

  4. #4
    Moderator DrewNJ's Avatar
    Join Date
    Dec 2005
    Location
    Marlton, NJ
    Posts
    3,716
    +1
    1
    Your fine Scott. Are you going HO pump for next year?
    Doug

  5. #5
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174
    Quote Originally Posted by DrewNJ View Post
    Your fine Scott. Are you going HO pump for next year?
    Doug
    Hey Doug,No I just jumped a nice wave but I guess the water wasn't deep enough,hit bottom broke the trim ring and nozzle!While taking it apart I also found a vane broken in the pump(explains cavitation,I thought it was my wear ring)Anyhow they say the old style is better for holeshot!I know this is pretty much a topend site but I like low end torque!Hope to be back in the water soon (drysuit)

    Scott

  6. #6
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174

    pump

    Doug this is my ski on Avon beach!No steering.Avon P.D.let me drive on the beach to pick it up!I'll be trailering (keep on floater in summer)it after it's back together so I might get back down to see you guys again if anyones up for it?

    Scott


  7. #7
    Moderator DrewNJ's Avatar
    Join Date
    Dec 2005
    Location
    Marlton, NJ
    Posts
    3,716
    +1
    1
    Damn...that sucks... Did you find all the parts you need? I know Joe (Savage) has a stator section...I might have one too..would have to look around the garage.. Exit nozzle, steering nozzle...could probably come up with as well..
    Let me know if I can help in any way...
    I'm done til spring.... I have motors to pull and hulls to true...

  8. #8
    pilo704's Avatar
    Join Date
    Jul 2008
    Location
    dirty jerzz
    Posts
    830
    bro, you ride avon?? i thought its to cold to be out now? i got a suit and all that..

  9. #9
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174
    doug,thanks I have all of the parts coming(focal13)and should be up and running by the weekend!

    pilo704,yes it gets cold sometimes, I won't lie, but it's still fun!I just picked up a drysuit and facemask(wicked clown)You do have to let the ski warm-up a little longer,so the cylinder warms-up along with the piston and you avoid a cold seize(piston expands faster than the cylinder and locks-up)I'll pm you when its together and i'm going out and yes I usually go out of sharkriver inlet.
    Scott

  10. #10
    sharkriver's Avatar
    Join Date
    Dec 2007
    Location
    Wall N.J.
    Posts
    174
    Good jumping waves are usually close to the beach around here(unless you go to barneget light awesome waves even away from the beach!)!I miss getting in close to the beach all summer(swimmers and lifeguards don't like ski's)so I take advantage in the winter when noone's around!Cold yes,Fun Definately!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Genesis, no start, fuel pump does not run when cranking
    By RIDEH2O in forum Polaris Open Discussion
    Replies: 22
    Last Post: 08-20-2013, 05:10 PM
  2. 94 polaris 750 mfd. will my jetski start without hte mfd pluged in?
    By srt8charger in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-26-2012, 02:40 PM
  3. Cleaning out engine can I start without SC
    By Kinchyle in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-08-2009, 12:21 AM
  4. 650 WaveRunner will not start without starting fluid
    By GuateMan in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 01-03-2008, 12:39 PM
  5. Can you run ski without pump?
    By shooter98xpl in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 01-02-2006, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •