Results 1 to 4 of 4
  1. #1

    Join Date
    Jul 2005
    euxton nr chorley lancashire, england

    bleeps and dash on, with no lanyard

    has anyone come across this, my ski was running the dogs yesterday, untill this happened. it was still fast, but the cluster was still lit and bleeping, with no key ? whats wrong ?

  2. #2
    same thing happened to me, I changed the key and dashboard wire harness and everything was fine

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Long Island, NY
    replace the DESS post

    if u can find a used one... just make sure it's a 3-wire DESS post for your ski

  4. #4
    PEST!'s Avatar
    Join Date
    Jun 2008
    Rockledge Florida
    It is the DESS Post but I would get a new one. All the newer Skis are harder on the DESS because it controls all the power on and I have seen more fail this year than anytime in the last 5 years. The Reed switches inside the post stick on and it wont shut off the power. The Key is fine

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 226
    Last Post: 06-01-2015, 03:25 PM
  2. Need help with my X ECU and dash programming
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-28-2011, 07:34 PM
  3. Running race filter and D-plate with no EFI controller?
    By Fusion in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 05-24-2007, 08:00 PM
  4. Im sick of this, and im done with it..
    By waverider in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-24-2006, 11:09 AM
  5. PPG Power Pipe and IC plumbing with BOV
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 06-28-2005, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts