Results 1 to 8 of 8
  1. #1
    rxpvic's Avatar
    Join Date
    Jun 2006
    Location
    Tampa, Florida
    Posts
    258
    +1
    17

    Question on 2rude

    Has anyone run a 2rude charger with a riva ecu and 50lbs injectors, Or will I have to buy a rrfpr. I thought I read somewhere that you could maybe just run larger injectors. Thanks


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    The RIVA ECU and 50s are barely safe, if at all, with the RUDE 1 (atleast in cold weather). I'm not sure how well larger injectors would work with the RIVA ECU when it's mapped for 50s. Most, if not everyone, will tell you that you need to add the RRFPR. 55s will work in colder weather with the Rude 1. The 2 Rude is in a different class though.

  3. #3
    SHO stopper palmbeach jesse's Avatar
    Join Date
    Nov 2007
    Location
    palm beach fl
    Posts
    3,225
    id get the the rrfpr...

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Vic, you will also need the RRFPR with the 2rude

  5. #5
    Poppa Dawg's Avatar
    Join Date
    Dec 2005
    Location
    Alice. Texas
    Posts
    1,015
    +1
    49
    RXPVIC,

    Been running the Etech 140mm drop-in in my Rude Charger which I think is pretty close to what the 2Rude puts out. No problem for 2 months with the Riva ECU & 50# injectors. Depending on the weather the AFR's have been anywhere from 11.4 - 12.2 & this has been on the race course. I have a RRFPR & have not felt the need to put it in. I probably will eventually. Plugs have looked good & top of pistons have looked good. I will say I do put in a little race gas during a 1 hr. race just to cool things down a little during periods of extended stress. It would probably be safer to go ahead & use it if you are getting consistent boost over 13 # as in my area I hardly ever see anything more than 13+.
    Last edited by Poppa Dawg; 11-17-2008 at 10:20 PM. Reason: Add info.

  6. #6
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    You must have a stock intercooler or stock air intake or 120 degree water and air temperatures. If none of those are true then please check your exhaust manifold bell if it's stock. It might not be there anymore.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by Poppa Dawg View Post
    RXPVIC,

    Been running the Etech 140mm drop-in in my Rude Charger which I think is pretty close to what the 2Rude puts out. No problem for 2 months with the Riva ECU & 50# injectors. Depending on the weather the AFR's have been anywhere from 11.4 - 12.2 & this has been on the race course. I have a RRFPR & have not felt the need to put it in. I probably will eventually. Plugs have looked good & top of pistons have looked good. I will say I do put in a little race gas during a 1 hr. race just to cool things down a little during periods of extended stress. It would probably be safer to go ahead & use it if you are getting consistent boost over 13 # as in my area I hardly ever see anything more than 13+.
    Doug, the reason you have been able to get away with this is because the X models fuel pump is driven at 14.4 volts. The regular RXP/T pump runs at 12 volts.

    X models use 42 lb injectors but they really flow 50 lb hr with the over driven fuel pump.

  8. #8
    Poppa Dawg's Avatar
    Join Date
    Dec 2005
    Location
    Alice. Texas
    Posts
    1,015
    +1
    49
    Guess I should have specified that I have a X boat. Sorry for any confusion. Put the RRFPR on & don't look back!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question on flushing intercooler /exhaust
    By Hecyan in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-25-2006, 09:38 PM
  2. Question on my GTX
    By DeeGee in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-14-2006, 10:26 AM
  3. Question on impeller pitch....14/19...14/17....15/20...?
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 04-24-2006, 05:07 AM
  4. Questions on ride plates?
    By r33pwrd in forum Yamaha PWC Performance (2-stroke)
    Replies: 34
    Last Post: 03-27-2006, 10:19 AM
  5. question on the ecu on a 1503 4-tec
    By chazavw in forum 4-Tec Performance
    Replies: 18
    Last Post: 12-23-2005, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •