Results 1 to 7 of 7
  1. #1
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30

    Anyone running the Advent T-4?

    I have not heard any news of these yet. Anybody? 1300's, 1200R's, 65U 1200's, 800's anybody tried them yet?
    I know Greg has sold several of them.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	at_7456-300.jpg 
Views:	57 
Size:	738.8 KB 
ID:	104946  


  2. #2
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    I was going to try one a while back but gave up. Greg missed the boat. Way too much money and no need for it anymore.

  3. #3
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Quote Originally Posted by krispaintballz View Post
    I was going to try one a while back but gave up. Greg missed the boat. Way too much money and no need for it anymore.
    How much was he asking for the old school version?

  4. #4
    Bartlesville OK syclonedriver's Avatar
    Join Date
    Jul 2008
    Posts
    133

    Has it been 2 weeks already?

    Was this finally released? EFI and ignition both working correctly? I would love to have programable EFI in my boat.

  5. #5
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by syclonedriver View Post
    Was this finally released? EFI and ignition both working correctly? I would love to have programable EFI in my boat.
    no

  6. #6
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    He called me a month ago. He said he was ready to sell them as ignitions only. Can be used in tandem with the riva efi controller. Wanted 1000+. I haven't been on my ski in months so I declined. I am just going to run my 1390 setup almost as is till the end of next summer and sell it. I just want to enjoy the ski now since I have it running A+++.

    I think he could sell a few more if they had the EFI working.... but sadly I don't think that will happen. The boat has left.

  7. #7
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    What he told me when i was going to get it was 1200 or something for the 65U non PV and 1200r PV carbed. 1475 for the EFI version, which was not being released yet because they had to reprogram it. You can buy the 1200 version and there is a plug and play add on to make it run the efi skis. This add on was 200.00.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone running the groupk 1390 kit?
    By yamahafreek in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 08-24-2015, 01:45 PM
  2. Anyone running the R&D 160mm impeller housing/prop on an FZ or FX SHO?
    By Ski Hacks MG in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-12-2015, 04:17 PM
  3. Is anyone running the R&D Thermostat option?
    By JoeyDFZS in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 12-26-2012, 06:39 PM
  4. Anyone running the SS wear ring sold on ebay?
    By snowrunner in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-19-2009, 07:18 PM
  5. Is anyone running the open loop plate mod?
    By bankyf in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-06-2008, 04:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •