Results 1 to 5 of 5
  1. #1
    Wakeskate or Die!!! RobbieMWD's Avatar
    Join Date
    May 2008
    Location
    Burleson, TX.
    Posts
    375

    Riva Sponson Install Question

    Man I feel stupid. I can't figure out how to get the Riva sponson backing to align with the studs sticking out of the hull. I cleaned off the silicone, got them straight and is still just dosen't align perfect. Is there something I'm missing? I have read the instructions over and over and still can't figure it out. Has anyone else ran into this? I'm kind of tired and frustrated, so this might be part of it. I just figured I'd thow them on real quick and it's kicking my butt.


  2. #2
    EH Team Water Pig's Avatar
    Join Date
    Oct 2007
    Location
    St. Catharines, Ontario, CANADA
    Posts
    773
    +1
    66

    Riva Sponsons

    Robbie,

    I had the same problem on my RXP-X.
    There seems to be an alignment problem with the Riva backing plate. I think the plastic is slightly bent or warped or simply mis-aligned so it doesn't match up very well.
    I played with mine for a long time then I finally snugged up the rear three studs in place and used a small hydraulic jack to gently push the front end of the backing plate up about an 1/8 of an inch and then snugged it up into place on that stud and then tightened the whole mess down and I was done. FYI

    Gord

  3. #3
    salsa's Avatar
    Join Date
    Sep 2007
    Location
    des moines iowa
    Posts
    134
    I too had this problem with the Riva backing/mount. The right side went on easily, but the left was very warped. I have a double trailer with a center walk/plank, so my dad used a 2 x 4 to push it into position while I started the fasteners. Whew, that was a chore, but got it together with no issues to date. Just one of those things I guess.

  4. #4
    Wakeskate or Die!!! RobbieMWD's Avatar
    Join Date
    May 2008
    Location
    Burleson, TX.
    Posts
    375
    Thanks for the help. I didn't even try anymore today. I was also thinking I might try to open the opening a little bit on the back of the Riva mount. I really don't see why it has to be as tight of a fit as it is. Maybe just open it up a hair. Does anyone see a problem with me doing that?

  5. #5
    EH Team Water Pig's Avatar
    Join Date
    Oct 2007
    Location
    St. Catharines, Ontario, CANADA
    Posts
    773
    +1
    66

    Sponsons

    Just give it a little english like we said. The small jack works great and it will push it into place just fine. No other mods necessary.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sponson install question?
    By tbaker in forum Polaris Open Discussion
    Replies: 13
    Last Post: 07-16-2008, 05:51 PM
  2. Riva Intercooler install questions...
    By aha in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-26-2008, 11:21 PM
  3. Replies: 3
    Last Post: 04-09-2007, 10:33 PM
  4. Riva Head Installation question
    By howestek in forum Yamaha PWC Performance (2-stroke)
    Replies: 28
    Last Post: 03-04-2007, 08:51 AM
  5. Question on Riva Sponsons install...just wondering?
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-14-2006, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •