Page 1 of 22 1 2 3 11 ... LastLast
Results 1 to 10 of 216
  1. #1
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1

    Start of the PRO785 PROJECT!!!!

    Hello all, as you know getting ready to tear down my pro 785. On the rebuild should I go back stock reeds or buy upgrade and if I do up grade will I need to rejet carbs? I really would not want to get into rejeting carbs right now. any help would be great! Hey may be in the wrong part of the forum. Please direct me in the right place so I can keep everyone posted on prog. Please if you have any tips or ideas let me know, Iam keeping a note book by the comp. Thanks!!!!!


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The PRO is already a damn quick ride but if you're going to upgrade, the reeds never hurt and it's a nice idea to have them fresh. Randy at Watcon is about the best there is when it comes to perfomance goodies for the PRO.

  3. #3
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Thanks, have already been in touch with Randy, he has got evrything I need.

  4. #4
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    The pro is in the shop and ready for the next fase
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IM006757.JPG 
Views:	145 
Size:	109.8 KB 
ID:	105419  

  5. #5
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Wrong pic
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IM006759.JPG 
Views:	149 
Size:	81.1 KB 
ID:	105420  

  6. #6
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    I am learning the ways of the comp. here she is one more time!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IM006760.JPG 
Views:	165 
Size:	99.8 KB 
ID:	105423  

  7. #7
    2000 pro 785 (son's) 1998 pro 785 (dads) old guy in mich's Avatar
    Join Date
    Aug 2007
    Location
    sw lower mich
    Posts
    350
    Quote Originally Posted by OLDJETSKIMAN View Post
    Please if you have any tips or ideas let me know, Iam keeping a note book by the comp. Thanks!!!!!
    be careful there with notebook, that kind of documentation could come back to bite yah if the wife ever see's it! lol

  8. #8
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1

    Thumbs down

    Your right better be carefull. Here some pics. of what I have found tonight. Check out the lower left drive/ pump nut and washer. also thought this was a set screw in the coupler but figured out it a grease fitting. Toke some work to get it out, rounded off. plus looks like the used the old vise grips on the drive shaft at one point.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IM006774.JPG 
Views:	75 
Size:	117.0 KB 
ID:	105699   Click image for larger version. 

Name:	IM006773.JPG 
Views:	77 
Size:	78.8 KB 
ID:	105700  

  9. #9
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Hey guys, two questions, when I took the water box out in the back found a disconnected cable that goes to the trim motor where does it hook too. Should the trim motor work with the ski not running? ( mine does not) or does it work just when the ski is running. Thanks

  10. #10
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Quote Originally Posted by OLDJETSKIMAN View Post
    Hey guys, two questions, when I took the water box out in the back found a disconnected cable that goes to the trim motor where does it hook too. Should the trim motor work with the ski not running? ( mine does not) or does it work just when the ski is running. Thanks
    There should be 2 wires blu/white and grn/white, and they connect inside the elect box on the blu/w and grn/w labled connectors on the circuit board. The trim switch also connects to those terminals. The trim only works when the engine is running, but you also can get it to run when you press the bilge pump button and trim switch.

Page 1 of 22 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Start of the 2016 Season
    By Takostubos in forum Flyboard
    Replies: 4
    Last Post: 05-17-2016, 12:58 PM
  2. Worth installing a new sprag for the start of the season?
    By MR MAC in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 02-08-2011, 08:07 AM
  3. First start of the season gone bad!
    By raiderteen in forum Yamaha Old School Skis
    Replies: 46
    Last Post: 03-03-2008, 10:51 PM
  4. Pics of the New Project
    By Region8Ultra250X in forum Videos & Pictures
    Replies: 2
    Last Post: 10-12-2007, 03:48 PM
  5. vid of the yama-doo SCIC 4tec SUV starting
    By rapidacceleration in forum 4-Tec Performance
    Replies: 11
    Last Post: 12-19-2006, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •