Results 1 to 10 of 10
  1. #1

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299

    maint flashing on display

    maint light turns on(display reads maint)and then turns off bu i have no codes
    I did a batt disconnect and this diddnt turn off the light.
    Any idea.
    Also it was hard to start 2 times today.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    That is just your maintenance reminder. It will go off after 5 seconds. Only the dealer can clear it using the BUDS computer.

  3. #3

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    this is set at normal hr intervals?
    I am taking it to a friend at my local dealer tomorow.
    I did have a few long crank times today but not consintan have any one seen this?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    Yes, the maintenance light comes on at preset intervals.

  5. #5
    818RXP's Avatar
    Join Date
    Jul 2005
    Location
    Winnetka, CA
    Posts
    78
    I'm not sure if it actually works but my 10 hr service was done a bit early. At the 10 hr point the " maint" would come on before starting. No problems or anything but just enough to make you nervous on a new ski. Called the dealer and they said to hold the MODE and SET bottons on the handlebars for a few seconds and it will reset.. Haven't tried it yet but hope it works.....

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    The maint light is preset to come on at 10 hours.

    Holding the buttons down used to work on older model skis, but not on these. It must be cleared by the dealer using his BUDS computer.

  7. #7

    Join Date
    Jun 2005
    Location
    Cayman Islands
    Posts
    705
    Actually if you press the set button 5 times it will disaper but as soon as you remove the safety lanyard and re-install it you will have to re-peat this step, like Hulk said the only way to remove it is with BUDS.

  8. #8

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    I went and saw a friend and he reset it for me.
    was a pain in the ass diddnt want to stay off but had no codes

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,962
    +1
    1,889
    Pressing the set button 5 times doesn't make it disapear. It disapears normally after 5 seconds. It only reappears once you put the lanyard on... then goes out in 5 seconds

  10. #10
    818RXP's Avatar
    Join Date
    Jul 2005
    Location
    Winnetka, CA
    Posts
    78
    Good to know.. They will probably charge $100 to do it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Maintenance" flashing on display - X series
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 8
    Last Post: 02-04-2009, 05:25 PM
  2. question about the riva ecu MAINT flashes on start up.
    By aussie rxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-24-2008, 09:15 AM
  3. 04 RXP-MAINT flashes for 10 seconds on Start.
    By -=aLiEno4RXP=- in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-16-2008, 12:14 AM
  4. 2004 RXP - "MAINT" flashes on Dashboard
    By premlulla in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-07-2007, 12:21 PM
  5. MAINT Flashes on controls...
    By majundecid in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 07-17-2006, 05:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •