Results 1 to 7 of 7
  1. #1
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366

    Project Sleeper, GTX

    lol, I have a 02 gtx regular that I just bought, It has a blown engine, the rear connecting rod came apart.
    And I also have a 03 GTX supercharged that was bought without a title and I cant get it so I gave up,

    So what im going to do is put the engine in the 02, But while I have the engine out i want to fix the super charged engine, it has a few little problems, I never got to ride it yet, I tryed to take it out and it would get about 50+mph and HI-TEMP would come up, well it pisses me off because I just replaced the rideplate on it, because this is what it was doing before.

    So I will check every thing, water pump, head gasket, head and block for cracks, water temp sensor, compression test, oil system and all that crap.


    Is there anything else that I should check?

    I have a new battery rideplate and impeller houseing to put on it already.

    It will look like a regular one till i take off.


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You might try pulling the J-pipe to see if the 4 holes are blocked and not allowing enough water into the exhaust. These holes could also be blocked by the hose clamps... Ron

  3. #3
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    cool thanks.

  4. #4
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Quote Originally Posted by King_Of_Fun View Post
    You might try pulling the J-pipe to see if the 4 holes are blocked and not allowing enough water into the exhaust. These holes could also be blocked by the hose clamps... Ron

    yes thats what id try first.

  5. #5
    check ur ic to c if it stoped up my riva ic stoped up befor and i had to back flush it

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    There's no IC on an '03 SC unless it was added. That's why I said to check the pisser holes on the j-pipe... Ron

  7. #7
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    yeah I just have a ride plate.

    Im going to have alot of parts left over if someone wants to buy something it could fund some of this.

    I just bought a guage cluster from shibby and this 02 came with one.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Project SST GTX
    By FrankieD in forum Sea Doo Build Threads
    Replies: 1
    Last Post: 07-10-2011, 03:26 AM
  2. 03 gtx sleeper
    By yellow jacket in forum 4-Tec Performance
    Replies: 54
    Last Post: 04-20-2009, 01:25 PM
  3. Planning a "Sleeper" Genesis project
    By SCXtrmSnwNWtr in forum Polaris PWC Performance
    Replies: 23
    Last Post: 05-30-2008, 10:08 AM
  4. 01' gtx project pics
    By TX21 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-07-2007, 04:54 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •