Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5

    oil inside hose from S/C to throttle plate

    Crap man, anyone seen this? I'm catching my oil in a catchcan, but I have oil inside my hose from S/C to throttle????? Would have to be S/C shaft oil seal wouldn't it?"?


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    More details would be very helpfull... mods, hours... etc.

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Pirates81 View Post
    Crap man, anyone seen this? I'm catching my oil in a catchcan, but I have oil inside my hose from S/C to throttle????? Would have to be S/C shaft oil seal wouldn't it?"?
    Would think so..I would pull your SC out and split the case and check behind the impeller...BUT like Big daddy stated what mods if any on your machine..

  4. #4
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Not a lot of mods. Just had S/C rebuilt. 240 hours on engine.

  5. #5
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by Pirates81 View Post
    Not a lot of mods. Just had S/C rebuilt. 240 hours on engine.
    I don't spose your running an x-charger?

  6. #6
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by monaroman76 View Post
    I don't spose your running an x-charger?
    NO stock S/C wheel. Guys I just got this S/C rebuilt. Does anyone have any ideas where this oil is coming from? When I pulled out my stock intercooler it was coated in a nice film of oil!!!!!!

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Pirates81 View Post
    NO stock S/C wheel. Guys I just got this S/C rebuilt. Does anyone have any ideas where this oil is coming from? When I pulled out my stock intercooler it was coated in a nice film of oil!!!!!!
    Is your charger still blowing oil now after rebuilding That oil could be left over from prior SC problems.

    I would pull the charger out and take a closer look... or take it back to the one responsible for the rebuild.

    This has not been a common problem on the 215 SC

  8. #8
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by bigdaddyRXP View Post
    Is your charger still blowing oil now after rebuilding That oil could be left over from prior SC problems.

    I would pull the charger out and take a closer look... or take it back to the one responsible for the rebuild.

    This has not been a common problem on the 215 SC
    I might have gotten screwed by the Seadoo dealer on this one. I have noticed ever since the rebuild by rpm's have been down about 100-200. I used to run 8100 consistently, after rebuild only 7900-8000. Wonder if the oil is causing problems already?

  9. #9
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    just asking....but, is the oil level correct? Just wondering if a slightly higher than normal level cause oil to accumulate in the catch can?

  10. #10
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Pirates81 View Post
    I might have gotten screwed by the Seadoo dealer on this one. I have noticed ever since the rebuild by rpm's have been down about 100-200. I used to run 8100 consistently, after rebuild only 7900-8000. Wonder if the oil is causing problems already?
    Sounds like it Your pumping oil into the intake causing 2 issues... clogging your IC making it less effective, and pumping oil into your air to fuel mixture.

    I'd take the ski back to your dealer

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts black intake hose from intake box to Supercharger inlet
    By JoeyDFZS in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-14-2013, 05:05 AM
  2. WTB Hose from rear waterbox to exhaust outlet for a Pro785
    By ho11stien in forum Polaris Classifieds
    Replies: 17
    Last Post: 06-06-2012, 02:54 AM
  3. Moving Throttle from Right Side to Left Side
    By PWCGEEK in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 04-18-2008, 01:59 AM
  4. Replacement Hoses from Exhaust to Head
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-17-2007, 04:02 PM
  5. hose from exhaust to engine??
    By wavehummer in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-30-2006, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •