Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 67
  1. #1
    Ride Hard! aha's Avatar
    Join Date
    Jul 2005
    Location
    Covina, Ca
    Posts
    2,009
    +1
    11

    Pump Ext Mod: Broken Drive shaft

    Hey guys here is a pic of my driveshaft after 10 minutes of use. My pump shoe/motor should be aligned as back in June I had my dealer replace my pump shoe. Anyone got any idea on how to get a piece of stuck driveshaft out of the PTO/Motor?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00307.JPG 
Views:	572 
Size:	2.79 MB 
ID:	105587  


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by aha View Post
    Hey guys here is a pic of my driveshaft after 10 minutes of use. My pump shoe/motor should be aligned as back in June I had my dealer replace my pump shoe. Anyone got any idea on how to get a piece of stuck driveshaft out of the PTO/Motor?

    Oh crap, that is not good. Man i hate to see that.

    Glad you ok with no injuries from ejection or so i guess.

    I cant believe this, i put my kit thru the ringer yesterday. I guess i better check alignment.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by aha View Post
    Hey guys here is a pic of my driveshaft after 10 minutes of use. My pump shoe/motor should be aligned as back in June I had my dealer replace my pump shoe. Anyone got any idea on how to get a piece of stuck driveshaft out of the PTO/Motor?
    . Is that the riva extension?

  4. #4
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by aha View Post
    Hey guys here is a pic of my driveshaft after 10 minutes of use. My pump shoe/motor should be aligned as back in June I had my dealer replace my pump shoe. Anyone got any idea on how to get a piece of stuck driveshaft out of the PTO/Motor?
    OOhh snap I wish I could help, I don't even know where my PTO is

    Good luck!!

    Getting kinda scary..No way they can blame that on Frank..He's in Florida..haha..joking

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Sorry to see.....The cover is going to have to come off if it is not in the bearing.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Not good at all

    You won't have to remove the PTO to remove the broken piece.
    Will call you in a minute....

  7. #7
    ROTAX RACING performance
    Join Date
    Apr 2005
    Location
    sweden
    Posts
    1,462
    +1
    17
    just use a magnet, or wait for jerrys call

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    look at those splines left on the shaft... they are twisted ... that wasn't just a faulty ski component in my opinion... the shaft actually started twisting upon itself it looks like

  9. #9

    Join Date
    Feb 2008
    Location
    Massa Italy
    Posts
    414
    I have one new RIVA in box ready to install!!!!
    But instal or not istall this is the problem!!!!!!!
    To much problems
    dear Jerry I think I'll ship back to you

  10. #10
    GUITARMAN's Avatar
    Join Date
    Aug 2007
    Location
    Lake Dunlap, Texas
    Posts
    182
    wHAT THE???????????????????

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 FZR modded engine. Drive shaft Tunnel leak into hull. Anyone had this??
    By nz253 in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 09-29-2016, 04:24 PM
  2. GP1200R Broken Drive shafts
    By Almost in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-27-2012, 06:43 PM
  3. WTB WTB 99 XL700 Pump housing and possibly Drive shaft
    By NeVerMind in forum Yamaha Classifieds
    Replies: 2
    Last Post: 07-08-2010, 10:07 AM
  4. Broken drive shaft - seen this? w/ pics
    By Deanrw3 in forum 2-Stroke Performance
    Replies: 31
    Last Post: 06-17-2010, 03:27 PM
  5. Broken drive shaft
    By Trimer in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-11-2006, 01:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •