Results 1 to 5 of 5
  1. #1

    where is it going

    just had my rxpx winterized and discussed with them that I noticed I am using oil about 1 pint per 10 hrs. They did a complete engine compression check nothing found . I have owned at least 6 new skis all seadoo this is the first to use oil . They also checked the pcv valve hose and it had minor if any oil residue in it. Is this oil blowing by the exhaust?The plugs are not fouled nor does it run bad it seems odd thanks


  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You might try pulling the hose off the SC to see if the SC is leaking oil and accumulating in the IC... Ron

  3. #3
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Its coming out through the SC shaft seal. Very common on 08 chargers because of the oiling system built into the charger. There is a how to on blocking the oil hole on the 08 charger to eliminate this problem

  4. #4
    Thanks any way I can do a visual check on this such as oil on the s/c wheel? If I do nothing will this cause a catastrofic failuer of the hole system or will the extra lubrication in the s/c give added insurance or protection. I did read that they added an oil galley to the s/c which was not on my 2004 and I was just wondering if there was enough oil on it to thro it out of balance? will check back later

  5. #5
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Should not cause any problems as long as you keep an eye on the oil level. To check for this prob. just take the hose off going from SC to IC and see if there is any oil or oil residue in it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki 750SS Drain Plug-Where is it???
    By jarcynvicnchris93 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 06-08-2008, 09:13 PM
  2. Bilge Blower Is Week' Then Gets Strong' Is it Going Bad?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-25-2007, 08:37 PM
  3. Where is it coming from HELP !!!! SOS
    By jmaxy in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-15-2007, 06:25 AM
  4. Where'd it go?
    By IowanGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-04-2007, 08:41 PM
  5. Lost RPM, where did it go???
    By DandSPro in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-09-2006, 06:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •